Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1090

Javadoc generation errors

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: puppet
    • Labels:
      None
    • Similar Issues:

      Description

      Perhaps a puppet issue since jar is missing? I hate the INFRA components

      Related to https://github.com/jenkins-infra/javadoc/pull/7

      Also, in the tar generated at https://ci.jenkins.io/job/Infra/job/javadoc/job/master/ contains an empty byShortName dir, probably also caused by the failure to extract core Javadocs.

        Attachments

          Activity

          rtyler R. Tyler Croy added a comment -

          So what is the actual javadoc error? I don't see anything in this ticket description which is actionable by anybody.

          danielbeck Daniel Beck added a comment -

          As the linked PR states,

          ./scripts/generate-javadoc.sh: line 23: jar: command not found

          rtyler R. Tyler Croy added a comment -

          I understand that from the pull request, but this was assigned to me and I don't know why.

          If the scripts aren't able to find the jar command, which I would assume the jdk8 tools installer should installer, then fix the scripts or change the Jenkinsfile to use a proper openjdk container.

          danielbeck Daniel Beck added a comment -

          R. Tyler Croy

          this was assigned to me and I don't know why.

          You're the default assignee of the puppet component I specified, as I didn't understand what was going on, and I suspected

          Perhaps a puppet issue since jar is missing?


            People

            Assignee:
            danielbeck Daniel Beck
            Reporter:
            danielbeck Daniel Beck
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: