Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1243

Pipeline: Job 2.12.1 shows up in LTS feed ahead of Jenkins 2.60 it depends on

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Trivial
    • Resolution: Not A Defect
    • Component/s: update-center
    • Labels:
    • Environment:
      Jenkins 2.46.3 LTS, Pipeline: Job (workflow-job) 2.11.1
    • Similar Issues:

      Description

      This morning I checked for plugin updates and was surprised to see the 2.12.1 release of the Pipeline Job and 2.6 release of Pipeline SCM Step plugins show up, given that I'm not running Jenkins 2.60, as they require. The warning it showed ("Warning: This plugin is built for Jenkins 2.60 or newer. Jenkins will refuse to load this plugin if installed.") was definitely helpful, as I now know not to upgrade these until I'm running 2.60+, but I was surprised to see them show up in the LTS feed at all.

      Shouldn't the plugin page only show updates that are applicable to the LTS version currently being run? 

      EDIT: When I originally logged this, I was midway through an upgrade from 2.11 to 2.11.1 – I'd installed it, but hadn't bounced the service yet – so was seeing the 2.12.1 upgrade as being an option for the 2.11 version I was running at the time. Post-bounce, I now see the 2.12.1 upgrade as an option against the 2.11.1 version I'm running. Same result, just without the gray background from earlier.

        Attachments

          Activity

          medianick Nick Jones added a comment -

          As far as I know, that's the URL that has been there since I first installed Jenkins a couple years ago. What is the correct one to be using for the LTS branch, Daniel Beck?

          medianick Nick Jones added a comment -

          Checking the system this morning, that URL dates back to at least November 7, 2014, when I started tracking config changes against what was then a Jenkins 1.580.1 installation. So perhaps an older version of Jenkins used this URL originally, and at some point it officially changed but didn't update my existing config? At any rate, if there's a more appropriate one to use for LTS releases, I'm happy to configure it; I just need to know what it is. I can't find it at https://jenkins.io/download/lts/#switching-from-weekly-to-lts. JENKINS-19771 seems to suggest that the URL I have is the correct one for LTS (apart from http vs. https). Regardless, I would just like to know what the correct URL to configure for an LTS installation should be at this point. Thanks!

          danielbeck Daniel Beck added a comment -

          Nick Jones As I wrote above,

          The default URL http://updates.jenkins-ci.org/update-center.json can be used for any Jenkins instance; query parameters will result in redirects to the appropriately tiered update site

          danielbeck Daniel Beck added a comment -

          Nick Jones You wrote above:

          the URL is "https://updates.jenkins-ci.org/stable/update-center.json".

          and then

          JENKINS-19771 seems to suggest that the URL I have is the correct one for LTS (apart from http vs. https).

          when the linked issue states (wrongly)

          a newly created JENKINS_HOME and correctly set environment variable, the update site points to the non-LTS version: http://updates.jenkins-ci.org/update-center.json. It should however point to http://updates.jenkins-ci.org/stable/update-center.json

          as I explain in a comment while resolving that issue as Cannot Reproduce:

          a different update center JSON is served if the version passed in the parameter is an LTS version.

          Left unsaid by me is that this redirect logic only exists for the default URL; if you select one of the specific update sites that the default URL forwards you to, you configured Jenkins to download exactly that, rather what's appropriate for your version. "stable" is special as it's basically a symlink to whatever the latest stable release is, 2.60.x since yesterday.

          I also dug a little; the current tiered update sites exist since late 2014, but I also found references that we had "current" and "stable" before then, and a similar redirection mechanism, which meant even before then there was no need to change the update center URL.

          I have not found any references in Jenkins sources that there was ever a different default URL out of the box.

          medianick Nick Jones added a comment -

          Thanks, Daniel Beck. I've switched the URL to "http://updates.jenkins-ci.org/update-center.json". It sounds like it must have had this value originally, and I switched it at some point (not sure when, or what prompted me to do so). Perhaps I was misled by JENKINS-19771 or something like it into thinking the "stable" portion of the URL was necessary in order to get only LTS-specific updates. Thanks again for your time and thorough explanation.

           


            People

            Assignee:
            danielbeck Daniel Beck
            Reporter:
            medianick Nick Jones
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: