Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-3039

server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: community
    • Labels:
      None
    • Environment:
      Ubuntu
    • Similar Issues:

      Description

      We are unbale to install Jenkins on Ubuntu 16.04 . 

      This Ubuntu is installed on VirtualBox 

      apt-get install jenkins
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      The following packages were automatically installed and are no longer required:
      libevent-core-2.0-5 libllvm4.0 snapd-login-service
      Use 'apt autoremove' to remove them.
      The following additional packages will be installed:
      daemon
      The following NEW packages will be installed:
      daemon jenkins
      0 upgraded, 2 newly installed, 0 to remove and 7 not upgraded.
      Need to get 71.6 MB/71.7 MB of archives.
      After this operation, 74.6 MB of additional disk space will be used.
      Do you want to continue? [Y/n] y
      Err:1 https://pkg.jenkins.io/debian-stable binary/ jenkins 2.289.3
      server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
      E: Failed to fetch https://pkg.jenkins.io/debian-stable/binary/jenkins_2.289.3_all.deb server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

      E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
      root

       

      cat /etc/os-release
      NAME="Ubuntu"
      VERSION="16.04.7 LTS (Xenial Xerus)"
      ID=ubuntu
      ID_LIKE=debian
      PRETTY_NAME="Ubuntu 16.04.7 LTS"
      VERSION_ID="16.04"
      HOME_URL="http://www.ubuntu.com/"
      SUPPORT_URL="http://help.ubuntu.com/"
      BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
      VERSION_CODENAME=xenial
      UBUNTU_CODENAME=xenial
      root

        Attachments

          Activity

          Hide
          sephirothj Ronny Perinke added a comment - - edited

          Abhimanyu, be sure to update your packages before installing any new software. According to Lets Encrypt Certificate Compatibility, Ubuntu 16.04 supports the root CA but it requires updates.

          Show
          sephirothj Ronny Perinke added a comment - - edited Abhimanyu , be sure to update your packages before installing any new software. According to Lets Encrypt Certificate Compatibility , Ubuntu 16.04 supports the root CA but it requires updates.

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            sayhello2abhi2003 Abhimanyu
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: