Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-3061

Job Error java.lang.NoSuchMethodError

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Environment:
    • Similar Issues:

      Description

      With the new jenkins.war version 2308/2309 I get the follow error message

       

      [modules] $ D:\jenkins\tools\jdk8u265-b01/bin/java -Djavax.net.ssl.trustStore=D:\.ssh\maven\xxxx.keystore -cp D:\jenkins\jenkins\plugins\maven-plugin\WEB-INF\lib\maven35-agent-1.13.jar;D:\jenkins\tools\apache-maven-3.8.1\boot\plexus-classworlds-2.6.0.jar;D:\jenkins\tools\apache-maven-3.8.1/conf/logging jenkins.maven3.agent.Maven35Main D:\jenkins\tools\apache-maven-3.8.1 D:\jenkins\jenkins\war\WEB-INF\lib\remoting-4.10.jar D:\jenkins\jenkins\plugins\maven-plugin\WEB-INF\lib\maven35-interceptor-1.13.jar D:\jenkins\jenkins\plugins\maven-plugin\WEB-INF\lib\maven3-interceptor-commons-1.13.jar 55515
      <===[JENKINS REMOTING CAPACITY]===>channel started
      Aug 27, 2021 11:36:21 AM hudson.remoting.UserRequest perform
      WARNING: LinkageError while performing UserRequest:hudson.maven.Maven3Builder@66a3d691
      java.lang.NoSuchMethodError: org.apache.commons.lang.StringUtils.endsWithAny(Ljava/lang/String;[Ljava/lang/String;)Z
      at org.jenkins.ui.icon.Icon.toNormalizedIconName(Icon.java:221)
      at hudson.model.BallColor.<init>(BallColor.java:82)
      at hudson.model.BallColor.<clinit>(BallColor.java:57)

       

      When I switch back to version 2307 the Job runs without problems.

        Attachments

          Issue Links

            Activity

            guido17 Guido Forthofer created issue -
            guido17 Guido Forthofer made changes -
            Field Original Value New Value
            Component/s plugins.jenkins.io [ 24636 ]
            Labels error java.lang.nosuchmethod jenkins job error java.lang.nosuchmethod jenkins job maven
            kon Kalle Niemitalo made changes -
            Link This issue duplicates JENKINS-66598 [ JENKINS-66598 ]
            kon Kalle Niemitalo added a comment - - edited

            This looks like a duplicate of JENKINS-66522.

            kon Kalle Niemitalo made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            kon Kalle Niemitalo made changes -
            Link This issue duplicates JENKINS-66522 [ JENKINS-66522 ]
            kon Kalle Niemitalo made changes -
            Link This issue duplicates JENKINS-66598 [ JENKINS-66598 ]
            danielbeck Daniel Beck added a comment -

            This is the Jenkins project infrastructure team's issue tracker, please do not file Jenkins issues here.

            danielbeck Daniel Beck made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              guido17 Guido Forthofer
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: