Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-3067

Cannot install (or update) credentials plugin 2.6 SHA-256 validation fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: update-center
    • Labels:
      None
    • Environment:
    • Similar Issues:
    • Released As:
      credentials-2.6.1

      Description

      I cannot install version 2.6 of the credentials plugin on a new Jenkins server, or update an existing server from 2.5 to 2.6. I get this error:

      java.io.IOException: Downloaded file /var/lib/jenkins/plugins/credentials.jpi.tmp does not match expected SHA-256, expected 'aOL2h5pdLc9JurZ3f2StxSx6IB4dVCcMkNWPj7jwb2A=', actual 'jJUDrnXQLxirWW9U/HGMuNjFMt3HeN1xuAlb2crB6ts='

      I am using the default updates site.

        Attachments

          Activity

            People

            Assignee:
            wfollonier Wadeck Follonier
            Reporter:
            drdavew Dave
            Votes:
            5 Vote for this issue
            Watchers:
            11 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: