Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-3070

Default LDAP Plug v1.26 no longer installs with Jenkins v2.222.4

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: plugins.jenkins.io
    • Environment:
      Jenkins v2.222.4, default plugin for a new Jenkins server instance, running Jenkins.war on Windows Server 2019, OpenJDK 64-Bit Server VM 18.9 (build 11.0.12+7, mixed mode)
    • Similar Issues:

      Description

      One of the Jenkins default plugins named LDAP fails to install when creating a new instance of Jenkins v2.222.4.  The error observed in the application log is: 

      java.io.IOException: Failed to load: LDAP Plugin (1.26)

      • Jenkins (2.235.3) or higher required

      at hudson.PluginManager.dynamicLoad(PluginManager.java:942)
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:2122)
      Caused: java.io.IOException: Failed to dynamically deploy this plugin
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:2126)
      at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1806)
      at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
      at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)

        Attachments

          Activity

          Hide
          danielbeck Daniel Beck added a comment -

          Jenkins 2.222.4 is no longer supported by project infrastructure. Time to upgrade.

          Show
          danielbeck Daniel Beck added a comment - Jenkins 2.222.4 is no longer supported by project infrastructure. Time to upgrade.

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            billf William
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: