Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-727

slapd should have more file descriptors

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: ldap
    • Labels:
      None
    • Similar Issues:

      Description

      The startup script for slapd should give it more file descriptors.

      We had an outage today due to too many open files:

      May 31 15:34:34 localhost slapd[16431]: warning: cannot open /etc/hosts.allow: Too many open files
      May 31 15:34:34 localhost slapd[16431]: warning: cannot open /etc/hosts.deny: Too many open files
      May 31 15:34:34 localhost slapd[16431]: warning: cannot open /etc/hosts.allow: Too many open files
      May 31 15:34:34 localhost slapd[16431]: warning: cannot open /etc/hosts.deny: Too many open files
      May 31 15:34:34 localhost slapd[16431]: warning: cannot open /etc/hosts.allow: Too many open files
      May 31 15:34:34 localhost slapd[16431]: warning: cannot open /etc/hosts.deny: Too many open files
      May 31 15:34:35 localhost slapd[16431]: warning: cannot open /etc/hosts.allow: Too many open files
      May 31 15:34:35 localhost slapd[16431]: warning: cannot open /etc/hosts.deny: Too many open files
      May 31 15:34:35 localhost slapd[16431]: warning: cannot open /etc/hosts.allow: Too many open files
      May 31 15:34:35 localhost slapd[16431]: warning: cannot open /etc/hosts.deny: Too many open files
      May 31 15:34:35 localhost slapd[16431]: warning: cannot open /etc/hosts.allow: Too many open files
      May 31 15:34:35 localhost slapd[16431]: warning: cannot open /etc/hosts.deny: Too many open files
      

        Attachments

          Activity

          olblak Olivier Vernin added a comment -

          Since we move this application on Azure it didn't reproduce


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            rtyler R. Tyler Croy
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: