Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-861

https://updates.jenkins-ci.org/stable/updates/ no longer exists

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: etc, www
    • Labels:
      None
    • Environment:
      Ubuntu 14.04
    • Similar Issues:

      Description

      Upon restart of Jenkins, I am seeing these messages in the log:

      WARNING: Could not load json from https://updates.jenkins-ci.org/stable/updates/hudson.tasks.Maven.MavenInstal ler.json
      java.io.FileNotFoundException: https://updates.jenkins-ci.org/stable-2.7/updates/hudson.tasks.Maven.MavenInsta ller.json.html?id=hudson.tasks.Maven.MavenInstaller&version=1.651.1
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1835)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1440)
      at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
      at hudson.model.DownloadService.loadJSONHTML(DownloadService.java:188)
      at hudson.model.DownloadService$Downloadable.updateNow(DownloadService.java:402)
      at hudson.PluginManager.doCheckUpdatesServer(PluginManager.java:987)
      at jenkins.model.DownloadSettings$DailyCheck.execute(DownloadSettings.java:118)
      at hudson.model.AsyncPeriodicWork$1.run(AsyncPeriodicWork.java:99)
      at java.lang.Thread.run(Thread.java:745)

      Jul 14, 2016 8:56:06 AM hudson.model.DownloadService$Downloadable updateNow
      WARNING: No tool installer metadata found for hudson.tasks.Maven.MavenInstaller
      Jul 14, 2016 8:56:06 AM hudson.model.DownloadService$Downloadable updateNow
      WARNING: Could not load json from https://updates.jenkins-ci.org/stable/updates/hudson.tasks.Ant.AntInstaller. json
      java.io.FileNotFoundException: https://updates.jenkins-ci.org/stable-2.7/updates/hudson.tasks.Ant.AntInstaller .json.html?id=hudson.tasks.Ant.AntInstaller&version=1.651.1
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1835)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1440)
      at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
      at hudson.model.DownloadService.loadJSONHTML(DownloadService.java:188)
      at hudson.model.DownloadService$Downloadable.updateNow(DownloadService.java:402)
      at hudson.PluginManager.doCheckUpdatesServer(PluginManager.java:987)
      at jenkins.model.DownloadSettings$DailyCheck.execute(DownloadSettings.java:118)
      at hudson.model.AsyncPeriodicWork$1.run(AsyncPeriodicWork.java:99)
      at java.lang.Thread.run(Thread.java:745)

      Jul 14, 2016 8:56:06 AM hudson.model.DownloadService$Downloadable updateNow
      WARNING: No tool installer metadata found for hudson.tasks.Ant.AntInstaller
      Jul 14, 2016 8:56:07 AM hudson.model.DownloadService$Downloadable updateNow
      WARNING: Could not load json from https://updates.jenkins-ci.org/stable/updates/hudson.plugins.groovy.GroovyIn staller.json
      java.io.FileNotFoundException: https://updates.jenkins-ci.org/stable-2.7/updates/hudson.plugins.groovy.GroovyI nstaller.json.html?id=hudson.plugins.groovy.GroovyInstaller&version=1.651.1
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1835)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1440)
      at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
      at hudson.model.DownloadService.loadJSONHTML(DownloadService.java:188)
      at hudson.model.DownloadService$Downloadable.updateNow(DownloadService.java:402)
      at hudson.PluginManager.doCheckUpdatesServer(PluginManager.java:987)
      at jenkins.model.DownloadSettings$DailyCheck.execute(DownloadSettings.java:118)
      at hudson.model.AsyncPeriodicWork$1.run(AsyncPeriodicWork.java:99)
      at java.lang.Thread.run(Thread.java:745)

      Jul 14, 2016 8:56:07 AM hudson.model.DownloadService$Downloadable updateNow
      WARNING: No tool installer metadata found for hudson.plugins.groovy.GroovyInstaller
      Jul 14, 2016 8:56:07 AM hudson.model.DownloadService$Downloadable updateNow
      WARNING: Could not load json from https://updates.jenkins-ci.org/stable/updates/hudson.plugins.nodejs.tools.No deJSInstaller.json
      java.io.FileNotFoundException: https://updates.jenkins-ci.org/stable-2.7/updates/hudson.plugins.nodejs.tools.N odeJSInstaller.json.html?id=hudson.plugins.nodejs.tools.NodeJSInstaller&version=1.651.1
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1835)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1440)
      at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
      at hudson.model.DownloadService.loadJSONHTML(DownloadService.java:188)
      at hudson.model.DownloadService$Downloadable.updateNow(DownloadService.java:402)
      at hudson.PluginManager.doCheckUpdatesServer(PluginManager.java:987)
      at jenkins.model.DownloadSettings$DailyCheck.execute(DownloadSettings.java:118)
      at hudson.model.AsyncPeriodicWork$1.run(AsyncPeriodicWork.java:99)
      at java.lang.Thread.run(Thread.java:745)

      Jul 14, 2016 8:56:07 AM hudson.model.DownloadService$Downloadable updateNow
      WARNING: No tool installer metadata found for hudson.plugins.nodejs.tools.NodeJSInstaller
      Jul 14, 2016 8:56:08 AM hudson.model.DownloadService$Downloadable updateNow
      WARNING: Could not load json from https://updates.jenkins-ci.org/stable/updates/hudson.tools.JDKInstaller.json
      java.io.FileNotFoundException: https://updates.jenkins-ci.org/stable-2.7/updates/hudson.tools.JDKInstaller.jso n.html?id=hudson.tools.JDKInstaller&version=1.651.1
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1835)
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1440)
      at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
      at hudson.model.DownloadService.loadJSONHTML(DownloadService.java:188)
      at hudson.model.DownloadService$Downloadable.updateNow(DownloadService.java:402)
      at hudson.PluginManager.doCheckUpdatesServer(PluginManager.java:987)
      at jenkins.model.DownloadSettings$DailyCheck.execute(DownloadSettings.java:118)
      at hudson.model.AsyncPeriodicWork$1.run(AsyncPeriodicWork.java:99)
      at java.lang.Thread.run(Thread.java:745)

      Jul 14, 2016 8:56:08 AM hudson.model.DownloadService$Downloadable updateNow
      WARNING: No tool installer metadata found for hudson.tools.JDKInstaller

        Attachments

          Activity

          mcsf M Chon added a comment - - edited

          So https://updates.jenkins-ci.org/update-center.json points to LTS?
          What is the URL for bleeding edge then?

          Also, I tried to find on the Jenkins website where it is documented what to set your URL to, and the site looks completely different now and I cannot find any information there.
          All I found was this page, which does not explain which URL you should point to if you want LTS:
          https://wiki.jenkins-ci.org/display/JENKINS/LTS+Release+Line

          danielbeck Daniel Beck added a comment -

          Jenkins appends a query parameter with the current Jenkins version to the request. Based on that, an appropriate update site is served.

          /update-center.json really is the only URL you need on updates.j.o.

          There's no documentation because there's literally NOTHING TO DO.

          mcsf M Chon added a comment - - edited

          OK, that kind of makes sense but 2 use cases are still undocumented, leaving people (like me) potentially confused:

          • If you want to switch from LTS to bleeding edge or vice versa. It's not obvious that this now takes place transparently
          • If you need to retrofit your Jenkins servers from selecting the legacy LTS URL to the new generic URL.
            Anyhow, I tested the URL and it does seem to work correctly. I tested this on a single server.
            (As stated above I did not write down which server I got the error message from so can't reproduce the original case unless I come across it again in the next few days)

          I take it based on your comments that version numbers of LTS releases and non-LTS releases will now never be shared, so that a version number will uniquely identify a server as tracking to either LTS or non-LTS?

          danielbeck Daniel Beck added a comment -

          If you want to switch from LTS to bleeding edge or vice versa. It's not obvious that this now takes place transparently

          Rare enough that it can be done manually.

          danielbeck Daniel Beck added a comment -

          Fixing as INFRA-885 as this appears to be more widespread that I assumed, three reports in the last week.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            mcsf M Chon
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: