Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1012

Task is Red even if the latest task run was successful

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • batch-task-plugin
    • None
    • Platform: All, OS: All

    Description

      As Ive played around with trying to get the batch task to work on Windows, I
      have 4 failed task builds/runs. Then when I had one success run of the task, the
      task icon would still be red. The task list shows red, and it is even red when I
      show the task item page. The build history for the task, shows 4 failed and 1
      success.

      Steps to reproduce:
      1. create a task with a command that will fail (ie executes a command that
      doesnt exists)
      2. Run the task 4 times
      3. Make sure that they fail
      4. Updated the task so it runs "dir" or "ls"
      5. Run the task
      6. Make sure that it works
      7. Show the task list
      8. The task will be still red
      9. Show the build history
      10. Make sure the build history contains one success

      Task list shows:
      Failed Test N/A 5 hours (#48-0) 1 second

      Build history on task page:
      Success #48-5 2007-nov-15 16:12:34
      Failed #48-3 2007-nov-15 15:23:44
      Failed #48-2 2007-nov-15 14:39:27
      Failed #48-1 2007-nov-15 14:37:01
      Failed #48-0 2007-nov-15 10:36:28

      Attachments

        Activity

          redsolo redsolo created issue -

          Fixed in batch-tasks 1.3.

          kohsuke Kohsuke Kawaguchi added a comment - Fixed in batch-tasks 1.3.
          kohsuke Kohsuke Kawaguchi made changes -
          Field Original Value New Value
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          jiai jiai added a comment -

          The fix was a bit overdone: Even if the task fails or is successful the, the
          task icon is now every time blue!

          I'm using Ant and found this out in the following configuration: Trying to start
          an ANT task without being in the correct directory (i.e. "Workbench" instead of
          "Workbench/Projectname"; the correct command sequence on Windows would have
          been: "cd Projectname && ant buildtarget")

          jiai jiai added a comment - The fix was a bit overdone: Even if the task fails or is successful the, the task icon is now every time blue! I'm using Ant and found this out in the following configuration: Trying to start an ANT task without being in the correct directory (i.e. "Workbench" instead of "Workbench/Projectname"; the correct command sequence on Windows would have been: "cd Projectname && ant buildtarget")
          jiai jiai made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          mindless Alan Harder added a comment -

          This seems to work ok now.. red/blue updates correctly based on last run of task. Please reopen issue and provide steps to reproduce problem if you still see anything wrong, thanks.

          mindless Alan Harder added a comment - This seems to work ok now.. red/blue updates correctly based on last run of task. Please reopen issue and provide steps to reproduce problem if you still see anything wrong, thanks.
          mindless Alan Harder made changes -
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Resolved [ 5 ]
          abayer Andrew Bayer made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 131085 ] JNJira + In-Review [ 200362 ]

          People

            kohsuke Kohsuke Kawaguchi
            redsolo redsolo
            Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: