Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10214

Copy artifacts doesn't copy correct artifacts from given matrix build id

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • copyartifact-plugin
    • None
    • Jenkins 1.418
      Copy Artifact Plugin 1.16

    Description

      I have configured "copy artifacts from another project" in promotion plugin with following settings

      • project name, – a matrix project name 'cneptune-release'
      • which build, – specific build
        • buildnumber, – $PROMOTED_NUMBER (the build I promoted)

      The plugin runs with following logs

      Promoting cneptune-release #26
      [cneptune-release] $ sh -xe /tmp/hudson4956727060021416147.sh
      + rm -rf archives
      + echo PROMOTED_NUMBER=26
      PROMOTED_NUMBER=26
      build hudson.tasks.Shell@74d431a1 SUCCESS
      Copied 1 artifact from cneptune-release » amd64-Debian-4.0 #5
      Copied 1 artifact from cneptune-release » amd64-Debian-5.0 #5
      Copied 1 artifact from cneptune-release » amd64,Debian-4.0 #13
      Copied 1 artifact from cneptune-release » amd64,Debian-5.0 #26
      Copied 0 artifacts from cneptune-release » i386,Debian-4.0 #6
      Copied 0 artifacts from cneptune-release » i386,Debian-5.0 #6
      build hudson.plugins.copyartifact.CopyArtifact@4870fa5b SUCCESS
      

      It should only copy the build with id #26 in the example, not #5, #6, #13.

      Attachments

        Activity

          People

            mindless Alan Harder
            kevincai Kevin Cai
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: