Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10379

Allowed statuses for Klocwork report are incorrect

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • klocwork-plugin
    • None
    • Jenkins 1.421 on RHEL 5.2, Klocwork 9.2.2, Klocwork plugin

    Description

      When trying to parse Klocwork 9.2.2 report, an error is raised:
      At line 25 of file:/tmp/workspace/job1/kwreport.xml:cvc-enumeration-valid: Value 'Not a Problem' is not facet-valid with respect to enumeration '[Analyze, Ignore, Not a problem, Fix, Fix in Next Release, Fix in Later Release, Defer, Filter]'. It must be a value from the enumeration.

      kwreport.xml comes straight from kwinspectreport 9.2.2.

      [I know it's not a core issue, but there's no klocwork component]

      Attachments

        Activity

          raspy Krzysztof Malinowski created issue -
          gbois Gregory Boissinot made changes -
          Field Original Value New Value
          Assignee gbois [ gbois ]

          Could you attach your Klocwork report?

          gbois Gregory Boissinot added a comment - Could you attach your Klocwork report?
          gbois Gregory Boissinot made changes -
          Status Open [ 1 ] In Progress [ 3 ]

          Attached Klocwork report illustrating problem. Note that status is 'Not a Problem' and not 'Not a problem'.

          raspy Krzysztof Malinowski added a comment - Attached Klocwork report illustrating problem. Note that status is 'Not a Problem' and not 'Not a problem'.
          raspy Krzysztof Malinowski made changes -
          Attachment out.xml [ 20686 ]
          gbois Gregory Boissinot made changes -
          Component/s klocwork [ 15906 ]
          Component/s core [ 15593 ]
          gbois Gregory Boissinot made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]
          raspy Krzysztof Malinowski made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

          The issue is not fixed. Do not close it

          gbois Gregory Boissinot added a comment - The issue is not fixed. Do not close it
          gbois Gregory Boissinot made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]

          Err... The issue state has been "Fixed" for more than two months now and no longer reproduces at my installation. So how exactly is it not fixed?

          raspy Krzysztof Malinowski added a comment - Err... The issue state has been "Fixed" for more than two months now and no longer reproduces at my installation. So how exactly is it not fixed?
          gbois Gregory Boissinot made changes -
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 140571 ] JNJira + In-Review [ 189126 ]

          People

            gbois Gregory Boissinot
            raspy Krzysztof Malinowski
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: