Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10455

Klocwork plugin running on linux master cannot retrieve report files from windows slave

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: klocwork-plugin
    • Labels:
      None
    • Environment:
      Jenkins running on Centos 5.5 x64, windows slave running on Windows server 2008 R2 64 bit.
    • Similar Issues:

      Description

      When I try to load the report files from my kw build on windows, I get the errors below. If I set up another test jenkins job that just reads the report file, and I copy it manually, then the plugin works (although all the file paths are incorrect).

      Note that I didn't include the kw report files, but I have validate that the files are correct by copying them to the master, where they load properly.

      Starting the klocwork analysis.
      Processing 1 files with the pattern 'kwrpt_eadev_c.xml'.
      Error on klocwork analysis: hudson.util.IOException2: remote file operation failed: d:\jenkins\workspace\nightly_trunk_klocwork_build at hudson.remoting.Channel@7f6ff8:mm-dev-build-01
      Build step 'Publish Klocwork test result report' changed build result to FAILURE
      Build step 'Publish Klocwork test result report' marked build as failure

        Attachments

          Activity

          kfhickel Kelly Hickel created issue -
          teetoivo Teemu Toivola added a comment -

          This same problem is also visible when a Linux master is used with Linux slaves:

          Starting the klocwork analysis.
          Processing 1 files with the pattern 'report.xml'.
          Error on klocwork analysis: hudson.util.IOException2: remote file operation failed: /build/Jenkins/slaves/slave1/workspace/Klocwork at hudson.remoting.Channel@6de8fb6a:ouling17
          Build step 'Publish Klocwork test result report' changed build result to FAILURE
          Build step 'Publish Klocwork test result report' marked build as failure

          If the xml file contains xml syntax errors then the errors get shown in the console log. So it would appear that the plugin is able to do some validations for the file but when the analysis starts then it isn't able to do some file operation.

          Jenkins ver. 1.425 and Klocwork Plug-in 1.1.

          gbois Gregory Boissinot made changes -
          Field Original Value New Value
          Component/s klocwork [ 15906 ]
          Component/s plugin [ 15491 ]
          gbois Gregory Boissinot made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          gbois Gregory Boissinot made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]
          kfhickel Kelly Hickel added a comment -

          I upgraded my install to the latest jenkins this morning, and version 1.2 of the klocwork plugin and I seem to have the same issue.

          d:\jenkins\workspace\nightly_trunk_klocwork_build>exit 0
          Starting the klocwork analysis.
          Processing 3 files with the pattern 'kwrpt_eadev_c.xml,kwrpt_qpasa_cpp.xml,kwrpt_qpasa_java.xml'.
          Error on klocwork analysis: hudson.util.IOException2: remote file operation failed: d:\jenkins\workspace\nightly_trunk_klocwork_build at hudson.remoting.Channel@ad5843:mm-dev-build-01
          Build step 'Publish Klocwork test result report' changed build result to FAILURE
          Build step 'Publish Klocwork test result report' marked build as failure

          kfhickel Kelly Hickel made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          gbois Gregory Boissinot added a comment -

          Could you specify your application web server (where the Jenkins runs) and attach your Klocwork reports?
          I'll try to reproduce it.

          kfhickel Kelly Hickel added a comment -

          cut down version of a kw report file.

          kfhickel Kelly Hickel made changes -
          Attachment kwrpt_small.xml [ 20718 ]
          kfhickel Kelly Hickel added a comment -

          I start it in standalone mode (command line below), and the java version I have is: 1.6.0_26-b03

          java -jar jenkins.war

          I've uploaded a cut down version of the report file with just one problem listed, I don't think that the contents of the file is the issue (just a guess), as it seems to be having trouble transferring the file.

          My jenkins is running on linux Centos 5.5, the windows slave is running windows 2008 server R2 x64, and I'm starting the jenkins slave over jnlp.

          gbois Gregory Boissinot added a comment -

          I tested it's OK for me.
          Are you sure you use the last version?
          Do you have remove the old expanded directory klocwork in $JENKINS_HOME/plugins?

          kfhickel Kelly Hickel added a comment -

          all I did was update jenkins from the Manage Plugins page, as I always do.

          I'll try removing the directory in a couple hours.

          Does anyone know if there's a way to turn up debugging for this plugin?

          I tried looking at the source, but the github link is still broken.

          kfhickel Kelly Hickel added a comment -

          well, THAT's embarrassing!

          I was certain that I updated the plugin and restarted but this morning when I checked, it still said there was a newer version.

          1.2 is working quite nicely!

          thanks for the fix.

          kfhickel Kelly Hickel added a comment -

          my mistake, I apparently didn't have the update properly installed. it is working correctly.

          kfhickel Kelly Hickel made changes -
          Fix Version/s current [ 10162 ]
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Closed [ 6 ]
          ciprian_vintea01 Ciprian Vintea added a comment -

          Hello, I also have the problem reported with version 1.15. I can't find any other new version (1.2 for example). What should I do?

          ciprian_vintea01 Ciprian Vintea added a comment -

          One correction from the previous comment. I thought that 1.2 is 1.20. So I'm using the latest version and I still have this problem. Some ideas? Thanks.

          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 140648 ] JNJira + In-Review [ 205244 ]

            People

            Assignee:
            gbois Gregory Boissinot
            Reporter:
            kfhickel Kelly Hickel
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: