Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11041

CI game fails with NPE

    XMLWordPrintable

Details

    Description

      after updating the plugin, all builds fail:

      ERROR: Publisher hudson.plugins.cigame.GamePublisher aborted due to exception
      java.lang.NullPointerException
      	at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:44)
      	at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:111)
      	at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:60)
      	at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:45)
      	at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:693)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:668)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:646)
      	at hudson.model.Build$RunnerImpl.cleanUp(Build.java:171)
      	at hudson.model.Run.run(Run.java:1420)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:230)
      

      Attachments

        Activity

          voorth voorth created issue -
          redsolo redsolo added a comment -

          Which versions of Jenkins and plugins are you using?

          redsolo redsolo added a comment - Which versions of Jenkins and plugins are you using?
          voorth voorth added a comment -

          Jenkins: 1.430
          CI game plugin: 1.18

          voorth voorth added a comment - Jenkins: 1.430 CI game plugin: 1.18
          voorth voorth added a comment - - edited

          AFAICT, there seems to be a null reference in ruleSet .
          Theoretically listener.getLogger() could also be the culprit, but the console output says otherwise:

          [ci-game] evaluating rule: Build result
          [ci-game] evaluating rule: Increased number of failed tests
          [ci-game] evaluating rule: Increased number of passed tests
          [ci-game] evaluating rule: Decreased number of failed tests
          [ci-game] evaluating rule: Decreased number of passed tests
          [ci-game] evaluating rule: Open HIGH priority tasks
          [ci-game] evaluating rule: Open HIGH priority tasks
          [ci-game] evaluating rule: Open NORMAL priority tasks
          [ci-game] evaluating rule: Open NORMAL priority tasks
          [ci-game] evaluating rule: Open LOW priority tasks
          [ci-game] evaluating rule: Open LOW priority tasks
          [ci-game] evaluating rule: HIGH priority PMD warnings
          [ci-game] evaluating rule: HIGH priority PMD warnings
          [ci-game] evaluating rule: NORMAL priority PMD warnings
          [ci-game] evaluating rule: NORMAL priority PMD warnings
          [ci-game] evaluating rule: LOW priority PMD warnings
          [ci-game] evaluating rule: LOW priority PMD warnings
          [ci-game] evaluating rule: New HIGH priority Findbugs warnings
          [ci-game] evaluating rule: New NORMAL priority Findbugs warnings
          [ci-game] evaluating rule: New LOW priority Findbugs warnings
          [ci-game] evaluating rule: New HIGH priority Findbugs warnings
          [ci-game] evaluating rule: New NORMAL priority Findbugs warnings
          [ci-game] evaluating rule: New LOW priority Findbugs warnings
          [ci-game] evaluating rule: Fixed HIGH priority Findbugs warnings
          [ci-game] evaluating rule: Fixed HIGH priority Findbugs warnings
          [ci-game] evaluating rule: Fixed NORMAL priority Findbugs warnings
          [ci-game] evaluating rule: Fixed NORMAL priority Findbugs warnings
          ERROR: Publisher hudson.plugins.cigame.GamePublisher aborted due to exception
          java.lang.NullPointerException
          	at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:44)
          	at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:111)
          	at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:60)
          	at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:45)
          	at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
          	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:693)
          	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:668)
          	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:646)
          	at hudson.model.Build$RunnerImpl.cleanUp(Build.java:171)
          	at hudson.model.Run.run(Run.java:1420)
          	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
          	at hudson.model.ResourceController.execute(ResourceController.java:88)
          	at hudson.model.Executor.run(Executor.java:230)
          
          voorth voorth added a comment - - edited AFAICT, there seems to be a null reference in ruleSet . Theoretically listener.getLogger() could also be the culprit, but the console output says otherwise: [ci-game] evaluating rule: Build result [ci-game] evaluating rule: Increased number of failed tests [ci-game] evaluating rule: Increased number of passed tests [ci-game] evaluating rule: Decreased number of failed tests [ci-game] evaluating rule: Decreased number of passed tests [ci-game] evaluating rule: Open HIGH priority tasks [ci-game] evaluating rule: Open HIGH priority tasks [ci-game] evaluating rule: Open NORMAL priority tasks [ci-game] evaluating rule: Open NORMAL priority tasks [ci-game] evaluating rule: Open LOW priority tasks [ci-game] evaluating rule: Open LOW priority tasks [ci-game] evaluating rule: HIGH priority PMD warnings [ci-game] evaluating rule: HIGH priority PMD warnings [ci-game] evaluating rule: NORMAL priority PMD warnings [ci-game] evaluating rule: NORMAL priority PMD warnings [ci-game] evaluating rule: LOW priority PMD warnings [ci-game] evaluating rule: LOW priority PMD warnings [ci-game] evaluating rule: New HIGH priority Findbugs warnings [ci-game] evaluating rule: New NORMAL priority Findbugs warnings [ci-game] evaluating rule: New LOW priority Findbugs warnings [ci-game] evaluating rule: New HIGH priority Findbugs warnings [ci-game] evaluating rule: New NORMAL priority Findbugs warnings [ci-game] evaluating rule: New LOW priority Findbugs warnings [ci-game] evaluating rule: Fixed HIGH priority Findbugs warnings [ci-game] evaluating rule: Fixed HIGH priority Findbugs warnings [ci-game] evaluating rule: Fixed NORMAL priority Findbugs warnings [ci-game] evaluating rule: Fixed NORMAL priority Findbugs warnings ERROR: Publisher hudson.plugins.cigame.GamePublisher aborted due to exception java.lang.NullPointerException at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:44) at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:111) at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:60) at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:45) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36) at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:693) at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:668) at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:646) at hudson.model.Build$RunnerImpl.cleanUp(Build.java:171) at hudson.model.Run.run(Run.java:1420) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:230)
          redsolo redsolo added a comment -

          Thanks for the help, i will have a look at it during this week.

          redsolo redsolo added a comment - Thanks for the help, i will have a look at it during this week.
          redsolo redsolo added a comment - - edited

          From your console output, I notice that there are double lines for Tasks, PMD and Findbugs which is strange... What other plugins are you using?
          PMD plugin
          Task plugin
          Findbugs plugin
          any other? Warnings or Checkstyle? Versions?

          Ive used the PMD, Task, Findbugs plugins with their latest versions and cant reproduce your error. Can you reproduce it every time on your server?

          redsolo redsolo added a comment - - edited From your console output, I notice that there are double lines for Tasks, PMD and Findbugs which is strange... What other plugins are you using? PMD plugin Task plugin Findbugs plugin any other? Warnings or Checkstyle? Versions? Ive used the PMD, Task, Findbugs plugins with their latest versions and cant reproduce your error. Can you reproduce it every time on your server?

          Same Here :

          • Jenkins ver. 1.450
          • Jenkins Continuous Integration game 1.18

          ERROR: Publisher hudson.plugins.cigame.GamePublisher aborted due to exception
          java.lang.NullPointerException
          at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:44)
          at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:111)
          at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:60)
          at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:45)
          at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
          at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:700)
          at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:675)
          at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:653)
          at hudson.model.Build$RunnerImpl.cleanUp(Build.java:171)
          at hudson.model.Run.run(Run.java:1453)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:238)

          junqueira_raphael Junqueira Raphael added a comment - Same Here : Jenkins ver. 1.450 Jenkins Continuous Integration game 1.18 ERROR: Publisher hudson.plugins.cigame.GamePublisher aborted due to exception java.lang.NullPointerException at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:44) at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:111) at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:60) at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:45) at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36) at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:700) at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:675) at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:653) at hudson.model.Build$RunnerImpl.cleanUp(Build.java:171) at hudson.model.Run.run(Run.java:1453) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:238)

          Note : removing old configuration seems to fix the problem

          junqueira_raphael Junqueira Raphael added a comment - Note : removing old configuration seems to fix the problem

          Code changed in jenkins
          User: Yann PETIT
          Path:
          src/main/java/hudson/plugins/cigame/model/ScoreCard.java
          src/test/java/hudson/plugins/cigame/model/ScoreCardTest.java
          http://jenkins-ci.org/commit/ci-game-plugin/8d7af4a10ae1965e50b0d92a8ad2ab100d344e8e
          Log:
          JENKINS-11041

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Yann PETIT Path: src/main/java/hudson/plugins/cigame/model/ScoreCard.java src/test/java/hudson/plugins/cigame/model/ScoreCardTest.java http://jenkins-ci.org/commit/ci-game-plugin/8d7af4a10ae1965e50b0d92a8ad2ab100d344e8e Log: JENKINS-11041

          Code changed in jenkins
          User: Olivier Lamy
          Path:
          src/main/java/hudson/plugins/cigame/model/ScoreCard.java
          src/test/java/hudson/plugins/cigame/model/ScoreCardTest.java
          http://jenkins-ci.org/commit/ci-game-plugin/4bdb6194ed2b54b51b96e599d4b5ddc07e48ec97
          Log:
          Merge pull request #4 from finalspy/master

          Fix for Jira JENKINS-11041
          Thanks !

          Compare: https://github.com/jenkinsci/ci-game-plugin/compare/fb30db1...4bdb619

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Olivier Lamy Path: src/main/java/hudson/plugins/cigame/model/ScoreCard.java src/test/java/hudson/plugins/cigame/model/ScoreCardTest.java http://jenkins-ci.org/commit/ci-game-plugin/4bdb6194ed2b54b51b96e599d4b5ddc07e48ec97 Log: Merge pull request #4 from finalspy/master Fix for Jira JENKINS-11041 Thanks ! Compare: https://github.com/jenkinsci/ci-game-plugin/compare/fb30db1...4bdb619
          evernat evernat added a comment -

          This is merged, so I suppose this is fixed.

          evernat evernat added a comment - This is merged, so I suppose this is fixed.
          evernat evernat made changes -
          Field Original Value New Value
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 141251 ] JNJira + In-Review [ 189517 ]

          People

            redsolo redsolo
            voorth voorth
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: