Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12234

Gradle Plugin incorrectly adds warning text to name of executed Javadoc task on console view

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      When using Gradle's Java plugin to generate Javadoc, the task name + any warning text is incorrectly added to the list of executed Gradle tasks. I've attached a screenshot that shows the problem. This makes the console output more difficult to use.

      I suspect this could be a Gradle issue rather than the Jenkins Gradle plugin.

        Attachments

          Activity

          stevendick stevendick created issue -
          fastblitzer Christian Gnüchtel added a comment -

          We are also facing this problem on Jenkins 1.484, Windows XP and Gradle plugin 1.20.

          I think it is not a Gradle problem, since the console output contains a line break after the task, if not on Jenkins:

          :compileJava
          C:\Programme\Jenkins\jobs\myjob\workspace\src\main\java\mypackage\MyClass.java:42: warning: non-varargs call of varargs method with inexact argument type for last parameter;
          

          But under Jenkins the console output looks like the following:

          :compileJavaC:\Programme\Jenkins\jobs\myjob\workspace\src\main\java\mypackage\MyClass.java:42: warning: non-varargs call of varargs method with inexact argument type for last parameter;
          

          Internally the HTML code is:

          <b class="gradle-task">compileJavaC:\Programme\Jenkins\jobs\myjob\workspace\src\main\java\mypackage\MyClass.java:42:<a name="gradle-task-1"></a></b>
          

          Is there any solution for this issue?

          jbochniak Jarek Bochniak added a comment - - edited

          As a workaround you can install Jenkins Simple Theme Plugin https://wiki.jenkins-ci.org/display/JENKINS/Simple+Theme+Plugin and use following CSS snippet:

          #console-outline-body a {
              display: block;
              padding: 5px 0;
              width: 157px;
              word-wrap: break-word;
          }
          

          it will reduce the width of the left column.

          gsimpson George Simpson added a comment -

          Too old to reproduce. Please open a new issue if this is still a problem.

          gsimpson George Simpson made changes -
          Field Original Value New Value
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 142556 ] JNJira + In-Review [ 205572 ]

            People

            Assignee:
            gbois Gregory Boissinot
            Reporter:
            stevendick stevendick
            Votes:
            7 Vote for this issue
            Watchers:
            7 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: