Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12757

It is not possible to use the RedHat/Fedora/Centos RPM:s on a private network.

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: other
    • Labels:
    • Similar Issues:

      Description

      The RedHat/Fedora/Centos RPM:s on a private network since the installer contains a yum configuration.
      A solution may be to split the rpm in two one for the core package and one for the package-management as done in the attached patch.

        Attachments

          Issue Links

            Activity

            persan_s_s Per Sandberg created issue -
            cmprea Colin Panisset added a comment - - edited

            This is similar to, but NOT a duplicate of https://issues.jenkins-ci.org/browse/JENKINS-11229 which was closed back in 2011 – but the problem in this case is that the jenkins.repo file should not be provided at all as part of the application package.

            This issue breaks local mirrors of the jenkins repo (which we do because we do not grant direct internet access to all internal systems).

            integer Kanstantsin Shautsou made changes -
            Field Original Value New Value
            Labels rpm
            integer Kanstantsin Shautsou made changes -
            Link This issue is related to JENKINS-17756 [ JENKINS-17756 ]
            integer Kanstantsin Shautsou added a comment -

            Disable repo in config file. Yum wouldn't replace it.

            oleg_nenashev Oleg Nenashev added a comment -

            Fixed in JENKINS-22690 (1.567+)

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-22690 [ JENKINS-22690 ]
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 143214 ] JNJira + In-Review [ 205680 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              persan_s_s Per Sandberg
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: