Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13705

Builds are sequential when there is a "Run conditional step" build step, even though the project is configured for concurrent execution

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      The description summary the problem. When there is "Run conditional step" then build on one node is waiting for the build on the other node complete, even though the project is configured for parallel builds.

        Attachments

          Activity

          sbalagiri BalagiriPrasad S created issue -
          sbalagiri BalagiriPrasad S made changes -
          Field Original Value New Value
          Description The reason for making "Invoke Maven Target" build step is not parallel may be because two concurrent maven calls can corrupt the repository. But when the two builds are happening on different nodes then jenkins should allow them. I am using nodelableparam to select different nodes, throttle Concurrent Builds configured to have 'Maximum Concurrent Builds Per Node' as 1.

          Attached the project files. In sleep.xml, update <host:port> with proper values
          The reason for making "Invoke Maven Target" build step not parallel, may be because two concurrent maven calls can corrupt the repository. But when the two builds are happening on different nodes then jenkins should run them in parallel. I am using nodelableparam to select different nodes, throttle Concurrent Builds configured to have 'Maximum Concurrent Builds Per Node' as 1.

          Attached the project files. In sleep.xml, update <host:port> with proper values
          sbalagiri BalagiriPrasad S made changes -
          Component/s run-condition [ 16129 ]
          Component/s core [ 15593 ]
          Description The reason for making "Invoke Maven Target" build step not parallel, may be because two concurrent maven calls can corrupt the repository. But when the two builds are happening on different nodes then jenkins should run them in parallel. I am using nodelableparam to select different nodes, throttle Concurrent Builds configured to have 'Maximum Concurrent Builds Per Node' as 1.

          Attached the project files. In sleep.xml, update <host:port> with proper values
          The description summary the problem. When there is "Run conditional step" then build on one node is waiting for the build on the other node complete, even though the project is configured for parallel builds.
          Labels concurrent-build parallel run-condition
          Summary Builds are sequential when there is a "Invoke Maven Target" build step, even though the project is configured for concurrent execution Builds are sequential when there is a "Run conditional step" build step, even though the project is configured for concurrent execution
          oleg_nenashev Oleg Nenashev made changes -
          Component/s conditional-buildstep [ 15947 ]
          imod Dominik Bartholdi added a comment -

          I'm not able to reproduce this. I tested it with a simple job only holding conditional buildsteps (single and multiple) - (within the conditions a shell step with "sleep 20" is executed). As long as there are more executors available, multiple executions are trigged in parallel.
          The only reason for the described behaviour to happen I can think of, is when there is a build step within the condition that causes it. Please test which of the steps in your scenario this could cause and feel free to reopen this issue.

          imod Dominik Bartholdi made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Resolved [ 5 ]
          imod Dominik Bartholdi made changes -
          Assignee Dominik Bartholdi [ imod ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 144172 ] JNJira + In-Review [ 190947 ]

            People

            Assignee:
            imod Dominik Bartholdi
            Reporter:
            sbalagiri BalagiriPrasad S
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: