Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-13859

Emulate clean check out seems to fail after upgrading to v1.4 of subversion plugin

    XMLWordPrintable

Details

    Description

      I had my job already set to "Emulate clean checkout"
      I upgraded to v1.4 of the plugin
      Set "Subversion Workspace Version" to 1.7
      Cleaned out the workspace.

      First build is successful, but now if I "Build Now" (with no svn changes) the project does not build because "All outputs are up-to-date".

      This shouldn't be the case since all output files should have been deleted on build.

      Note I also get AssertionError: appears to be using unpatched svnkit at jar:xxx/SVNEvent.class which is reported in JENKINS-13790

      Attachments

        Issue Links

          Activity

            redoranges Serge Dorna created issue -
            simabeis Marcel Beister made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-13844 [ JENKINS-13844 ]
            aristedes aristedes added a comment -

            This also happens for me with 1.7 workspace and 1.7 subversion server.

            aristedes aristedes added a comment - This also happens for me with 1.7 workspace and 1.7 subversion server.
            aristedes aristedes made changes -
            Link This issue is related to JENKINS-13835 [ JENKINS-13835 ]
            chris_lee Chris Lee added a comment -

            The solution for this (requires a code change) is detailed in JENKINS-13844

            chris_lee Chris Lee added a comment - The solution for this (requires a code change) is detailed in JENKINS-13844

            Seems to be a duplicate of JENKINS-13844, therefore resolving.

            forderud Fredrik Orderud added a comment - Seems to be a duplicate of JENKINS-13844 , therefore resolving.
            forderud Fredrik Orderud made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 144327 ] JNJira + In-Review [ 191032 ]

            People

              Unassigned Unassigned
              redoranges Serge Dorna
              Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: