Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14296

Doesn't mark build as unstable or failed if run condition fails

    XMLWordPrintable

Details

    Description

      Configure a job using conditional buildstep plugin.
      Choose a run condition, one that can fail.
      Choose option "On evaluation failure Mark build unstable".

      Make the evaluation of the condition to fail.
      Start the job.
      After finishing the job, the buildstep is not runned, as expected, but the build is not marked as unstable.
      The same happens if "Mark build as failure" option is selected.The build is always marked as succes without taking into account the value of this option.

      Attachments

        Issue Links

          Activity

            ace Adrian Vlad created issue -
            bap bap made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-14068 [ JENKINS-14068 ]
            bap bap added a comment -

            The "on evaluation failure" option allows you to select what happens if the run condition could not be evaluated to true or false - not what happens when the run condition says "don't run".

            bap bap added a comment - The "on evaluation failure" option allows you to select what happens if the run condition could not be evaluated to true or false - not what happens when the run condition says "don't run".
            domi Dominik Bartholdi made changes -
            Assignee domi [ domi ] bap [ bap ]
            bap bap added a comment -

            Cannot reproduce - can you provide an example of a run condition with the content that you use to make the evaluation fail?

            bap bap added a comment - Cannot reproduce - can you provide an example of a run condition with the content that you use to make the evaluation fail?

            closing because of no feedback

            domi Dominik Bartholdi added a comment - closing because of no feedback
            domi Dominik Bartholdi made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Resolved [ 5 ]
            fantastory Roman Wieczorek made changes -
            Link This issue is duplicated by JENKINS-34971 [ JENKINS-34971 ]
            ppothnis pavan pothnis made changes -
            Link This issue is blocking JENKINS-35169 [ JENKINS-35169 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 144928 ] JNJira + In-Review [ 191256 ]

            People

              bap bap
              ace Adrian Vlad
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: