Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14505

Delete button broken (and many more)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 1.474
    • Similar Issues:

      Description

      Many issues including:

      • Delete button now working when editing a list view
      • Drop lists not loading properly of some plugins
      • Delete Column button not working for sectioned view plugin
      • Delete build step not working
      • Many drop lists cannot add items (when configuring a job like the Release plugin)

      See also:

      The same issue happen on a Windows and a Linux Jenkins. Both run the 1.474 but have very different setups.

      Downgrading to 1.473 solves the issue.

        Attachments

          Issue Links

            Activity

            wernight wernight created issue -
            ohtake_tomohiro OHTAKE Tomohiro made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-14478 [ JENKINS-14478 ]
            wernight wernight made changes -
            Description Many issues including:
             - Delete button now working when editing a list view
             - Drop lists not loading properly of some plugins
             - Delete Column button not working for sectioned view plugin
             - Delete build step not working

            See also:
             - http://jenkins.361315.n4.nabble.com/hetero-list-quot-delete-button-quot-doesn-t-work-for-our-plugin-in-new-Jenkins-version-td4634675.html
             - Possibly broken by https://github.com/albgra/jenkins/commit/581b8256b10e1e74f9ec872664ae837c625a1d17
            Many issues including:
             - Delete button now working when editing a list view
             - Drop lists not loading properly of some plugins
             - Delete Column button not working for sectioned view plugin
             - Delete build step not working

            See also:
             - http://jenkins.361315.n4.nabble.com/hetero-list-quot-delete-button-quot-doesn-t-work-for-our-plugin-in-new-Jenkins-version-td4634675.html
             - Possibly broken by https://github.com/albgra/jenkins/commit/581b8256b10e1e74f9ec872664ae837c625a1d17

            The same issue happen on a Windows and a Linux Jenkins. Both run the 1.474 but have very different setups.

            Downgrading to 1.473 solves the issue.
            wernight wernight made changes -
            Description Many issues including:
             - Delete button now working when editing a list view
             - Drop lists not loading properly of some plugins
             - Delete Column button not working for sectioned view plugin
             - Delete build step not working

            See also:
             - http://jenkins.361315.n4.nabble.com/hetero-list-quot-delete-button-quot-doesn-t-work-for-our-plugin-in-new-Jenkins-version-td4634675.html
             - Possibly broken by https://github.com/albgra/jenkins/commit/581b8256b10e1e74f9ec872664ae837c625a1d17

            The same issue happen on a Windows and a Linux Jenkins. Both run the 1.474 but have very different setups.

            Downgrading to 1.473 solves the issue.
            Many issues including:
             - Delete button now working when editing a list view
             - Drop lists not loading properly of some plugins
             - Delete Column button not working for sectioned view plugin
             - Delete build step not working
             - Many drop lists cannot add items (when configuring a job like the Release plugin)

            See also:
             - http://jenkins.361315.n4.nabble.com/hetero-list-quot-delete-button-quot-doesn-t-work-for-our-plugin-in-new-Jenkins-version-td4634675.html
             - Possibly broken by https://github.com/albgra/jenkins/commit/581b8256b10e1e74f9ec872664ae837c625a1d17

            The same issue happen on a Windows and a Linux Jenkins. Both run the 1.474 but have very different setups.

            Downgrading to 1.473 solves the issue.
            jglick Jesse Glick made changes -
            Link This issue duplicates JENKINS-14514 [ JENKINS-14514 ]
            jglick Jesse Glick made changes -
            Link This issue duplicates JENKINS-14434 [ JENKINS-14434 ]
            jglick Jesse Glick made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            ircbot Jenkins IRC Bot made changes -
            Component/s ui-changes [ 16530 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 145141 ] JNJira + In-Review [ 191372 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              wernight wernight
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: