Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-14934

JENKINS-11366 (takes up too much space in /var/run) still not fixed in version 1.447

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Cannot Reproduce
    • core
    • None
    • Raspberry Pi running Raspbian
      Jenkins 1.447

    Description

      Jenkins attempt to use /var/run on startup but on low-spec systems (such as the Raspberry Pi) there is insufficient space

      This was apparently fixed and released in version 1.443, however version 1.447 (that I got from apt-get) still has the same issue which I have replicated below

      [Winstone 2011/10/16 13:38:21] - Beginning extraction from war file
      [Winstone 2011/10/16 13:38:23] - Error initializing web application: prefix []
      java.io.IOException: No space left on device
      at java.io.FileOutputStream.writeBytes(Native Method)
      at java.io.FileOutputStream.write(FileOutputStream.java:282)
      at winstone.HostConfiguration.getWebRoot(HostConfiguration.java:273)
      at winstone.HostConfiguration.<init>(HostConfiguration.java:73)
      at winstone.HostGroup.initHost(HostGroup.java:85)
      at winstone.HostGroup.<init>(HostGroup.java:45)
      at winstone.Launcher.<init>(Launcher.java:197)
      at winstone.Launcher.main(Launcher.java:398)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at Main._main(Main.java:268)
      at Main.main(Main.java:96)

      The mount command returns this:
      none on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)

      The df command returns this:
      none 50M 50M 0 100% /run

      Attachments

        Activity

          antonylees Antony Lees created issue -

          I looked at 1.478 debian package and it does extract things to /var/cache/jenkins.

          I suspect you are seeing what you are seeing because /etc/default/jenkins is marked as a configuration file, and during the upgrade you probably chose to keep your local version over the maintainer version.

          kohsuke Kohsuke Kawaguchi added a comment - I looked at 1.478 debian package and it does extract things to /var/cache/jenkins. I suspect you are seeing what you are seeing because /etc/default/jenkins is marked as a configuration file, and during the upgrade you probably chose to keep your local version over the maintainer version.
          kohsuke Kohsuke Kawaguchi made changes -
          Field Original Value New Value
          Assignee Kohsuke Kawaguchi [ kohsuke ]
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Resolved [ 5 ]
          antonylees Antony Lees added a comment - - edited

          Hmm strange as this was a new install, not an upgrade, so there is definitely something wrong with that version of Jenkins

          Basically all I did was:
          sudo apt-get install jenkins
          on a totally clean install of raspbian. It failed to start up for the reason I highlighted above

          antonylees Antony Lees added a comment - - edited Hmm strange as this was a new install, not an upgrade, so there is definitely something wrong with that version of Jenkins Basically all I did was: sudo apt-get install jenkins on a totally clean install of raspbian. It failed to start up for the reason I highlighted above
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 145635 ] JNJira + In-Review [ 191570 ]

          People

            kohsuke Kohsuke Kawaguchi
            antonylees Antony Lees
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: