Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15284

Selenium hub doesn't work on a server with multiple interface

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • selenium-plugin
    • None
    • red hat/ java 1.6

    Description

      When using the selenium hub on a server with more than one interface, selenium hub uses the wrong interface so our tests do not run.

      I was able to get selenium hub work by starting it manually specifying the interface to be used.
      java -jar selenium-server-standalone-2.25.0.jar -role hub -host 10.101.7.42

      Maybe a good solution would be to be able to specify the interface to listen to in jenkins (like it is done for the port).

      This issue is blocking us in our deployment of the selenium jenkins.
      Thanks for everything.

      Attachments

        Activity

          I believe it is already possible now to choose your own hostname/interface, please let me know if this is not what you need.

          mobrockers Rouke Broersma added a comment - I believe it is already possible now to choose your own hostname/interface, please let me know if this is not what you need.

          If your are using the default 4444 port, there is another process running on that port thus ehy you have a problem loading the hub. Can you try using another port for the hub and try again ? As far as I know, the -host should only bind it to o e interface while not specifying should listen on all.

          Thanks

          darkrift Richard Lavoie added a comment - If your are using the default 4444 port, there is another process running on that port thus ehy you have a problem loading the hub. Can you try using another port for the hub and try again ? As far as I know, the -host should only bind it to o e interface while not specifying should listen on all. Thanks

          what do you see when you check in the logs of jenkins ? any errors ?

          What's the output ewhen you do a "netstat -nlp" ?

          darkrift Richard Lavoie added a comment - what do you see when you check in the logs of jenkins ? any errors ? What's the output ewhen you do a "netstat -nlp" ?

          People

            darkrift Richard Lavoie
            yannick_roger Yannick ROGER
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: