Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-15284

Selenium hub doesn't work on a server with multiple interface

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • selenium-plugin
    • None
    • red hat/ java 1.6

    Description

      When using the selenium hub on a server with more than one interface, selenium hub uses the wrong interface so our tests do not run.

      I was able to get selenium hub work by starting it manually specifying the interface to be used.
      java -jar selenium-server-standalone-2.25.0.jar -role hub -host 10.101.7.42

      Maybe a good solution would be to be able to specify the interface to listen to in jenkins (like it is done for the port).

      This issue is blocking us in our deployment of the selenium jenkins.
      Thanks for everything.

      Attachments

        Activity

          yannick_roger Yannick ROGER created issue -
          yannick_roger Yannick ROGER made changes -
          Field Original Value New Value
          Attachment jenkins-15284.zip [ 22479 ]
          yannick_roger Yannick ROGER made changes -
          Attachment jenkins.log_bug_different_port [ 22483 ]
          mobrockers Rouke Broersma made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 146007 ] JNJira + In-Review [ 191740 ]

          People

            darkrift Richard Lavoie
            yannick_roger Yannick ROGER
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: