Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1560

Problem to view the detail of the findBug information

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • findbugs-plugin
    • None
    • Platform: All, OS: Linux

    Description

      Problem to view the detail of the findBug information

      We are using Hudson with the validation plugin. The main overview is displayed
      correctly (http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/).
      But after clicking to a package info the following exception occurs
      http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/package/

      Exception:
      javax.servlet.ServletException: java.util.NoSuchElementException: Package not
      found: xx.xxxxx.utils.misc.web
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:425)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:248)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch
      (NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:352)
      org.kohsuke.stapler.Stapler.service(Stapler.java:112)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:52)
      hudson.security.UnwrapSecurityExceptionFilter.doFilter
      (UnwrapSecurityExceptionFilter.java:28)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.ui.ExceptionTranslationFilter.doFilter
      (ExceptionTranslationFilter.java:166)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter
      (AnonymousProcessingFilter.java:125)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.ui.AbstractProcessingFilter.doFilter
      (AbstractProcessingFilter.java:271)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter
      (RememberMeProcessingFilter.java:142)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter
      (BasicProcessingFilter.java:173)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter
      (HttpSessionContextIntegrationFilter.java:249)
      hudson.security.HttpSessionContextIntegrationFilter2.doFilter
      (HttpSessionContextIntegrationFilter2.java:42)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      hudson.security.ChainedServletFilter.doFilter
      (ChainedServletFilter.java:44)
      hudson.security.HudsonFilter.doFilter(HudsonFilter.java:85)
      org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter
      (ReplyHeaderFilter.java:96)

      java.util.NoSuchElementException: Package not found: xx.xxxx.utils.misc.web
      hudson.plugins.findbugs.util.model.MavenModule.getPackage
      (MavenModule.java:109)
      hudson.plugins.findbugs.FindBugsResult.getDynamic
      (FindBugsResult.java:512)
      sun.reflect.GeneratedMethodAccessor747.invoke(Unknown Source)
      sun.reflect.DelegatingMethodAccessorImpl.invoke
      (DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:585)
      org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:103)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:248)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch
      (NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:352)
      org.kohsuke.stapler.Stapler.service(Stapler.java:112)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:52)
      hudson.security.UnwrapSecurityExceptionFilter.doFilter
      (UnwrapSecurityExceptionFilter.java:28)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.ui.ExceptionTranslationFilter.doFilter
      (ExceptionTranslationFilter.java:166)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter
      (AnonymousProcessingFilter.java:125)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.ui.AbstractProcessingFilter.doFilter
      (AbstractProcessingFilter.java:271)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter
      (RememberMeProcessingFilter.java:142)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter
      (BasicProcessingFilter.java:173)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter
      (HttpSessionContextIntegrationFilter.java:249)
      hudson.security.HttpSessionContextIntegrationFilter2.doFilter
      (HttpSessionContextIntegrationFilter2.java:42)
      hudson.security.ChainedServletFilter$1.doFilter
      (ChainedServletFilter.java:55)
      hudson.security.ChainedServletFilter.doFilter
      (ChainedServletFilter.java:44)
      hudson.security.HudsonFilter.doFilter(HudsonFilter.java:85)
      org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter
      (ReplyHeaderFilter.java:96)

      Attachments

        1. findbugs.xml.txt
          0.6 kB
        2. findbugs-warnings.xml
          242 kB
        3. findbugsXml.xml.txt
          3 kB
        4. findbugXmlxml.txt.txt
          5 kB

        Issue Links

          Activity

            pbolle pbolle created issue -
            drulli Ulli Hafner added a comment -

            Could you please help me by providing the following additional information?

            Does your project contain the package that is not found?

            What exactly is the link that you click? Is it really
            http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/package/?
            It should be something like
            http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/xx.xxxx.utils.misc.web/

            Do you have several maven modules in your job?

            If possible, please attach the findbugsXml.xml file of your project (or
            findbugs.xml).

            P.S. do you use version 2.4 of findbugs?

            drulli Ulli Hafner added a comment - Could you please help me by providing the following additional information? Does your project contain the package that is not found? What exactly is the link that you click? Is it really http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/package/? It should be something like http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/xx.xxxx.utils.misc.web/ Do you have several maven modules in your job? If possible, please attach the findbugsXml.xml file of your project (or findbugs.xml). P.S. do you use version 2.4 of findbugs?
            pbolle pbolle added a comment -

            Created an attachment (id=228)
            exception log

            pbolle pbolle added a comment - Created an attachment (id=228) exception log
            pbolle pbolle added a comment -

            Created an attachment (id=229)
            findbugs.xml

            pbolle pbolle added a comment - Created an attachment (id=229) findbugs.xml
            pbolle pbolle added a comment -

            Created an attachment (id=230)
            findbugsXml.xml

            pbolle pbolle added a comment - Created an attachment (id=230) findbugsXml.xml
            pbolle pbolle added a comment -

            Thank you for your very fast response.

            How can I find out that a package is not found?
            In the project are several maven modules.
            We are using findBugs Version 1.2.1. ([INFO] Using FindBugs Version: 1.2.1)
            We are not using findbugsXml.xml because we get an exception in Hudson (the
            Exception is attached in findbugXmlxml.txt).
            This was the resean for using findbugs.xml.

            In the atachmend you can find a findbugsXml.xml and a findbugs.xml. In the
            findbugsXml.xml I removed many AuxClasspathEntry.

            Yes we are calling a link like http://server/hudson/job/smsservice-doc-
            HEAD/11/findbugsResult/xx.xxxxx.sms.service/

            The build is executed on an remote machine. Could this be the problem?

            pbolle pbolle added a comment - Thank you for your very fast response. How can I find out that a package is not found? In the project are several maven modules. We are using findBugs Version 1.2.1. ( [INFO] Using FindBugs Version: 1.2.1) We are not using findbugsXml.xml because we get an exception in Hudson (the Exception is attached in findbugXmlxml.txt). This was the resean for using findbugs.xml. In the atachmend you can find a findbugsXml.xml and a findbugs.xml. In the findbugsXml.xml I removed many AuxClasspathEntry. Yes we are calling a link like http://server/hudson/job/smsservice-doc- HEAD/11/findbugsResult/xx.xxxxx.sms.service/ The build is executed on an remote machine. Could this be the problem?
            drulli Ulli Hafner added a comment -

            Added a new issue for the exception during parsing of findbugs on a remote machine.

            https://hudson.dev.java.net/issues/show_bug.cgi?id=1603

            drulli Ulli Hafner added a comment - Added a new issue for the exception during parsing of findbugs on a remote machine. https://hudson.dev.java.net/issues/show_bug.cgi?id=1603
            drulli Ulli Hafner made changes -
            Field Original Value New Value
            Status Open [ 1 ] In Progress [ 3 ]
            drulli Ulli Hafner made changes -
            Link This issue depends on JENKINS-1603 [ JENKINS-1603 ]
            drulli Ulli Hafner added a comment -

            I just tried to reproduce your error. When I read your findbugs.xml file I don't
            get the modules and packages overview as there is only one warning and package
            and module in it. Do you have several findbugs files in your build?

            As you noted in your comments you are have several maven modules?

            What is shown, if you go to
            http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/

            Is the module overview shown? Or do you see the packages overview? Or just the
            plain warnings? (See WIKI for the different type of views).

            drulli Ulli Hafner added a comment - I just tried to reproduce your error. When I read your findbugs.xml file I don't get the modules and packages overview as there is only one warning and package and module in it. Do you have several findbugs files in your build? As you noted in your comments you are have several maven modules? What is shown, if you go to http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/ Is the module overview shown? Or do you see the packages overview? Or just the plain warnings? (See WIKI for the different type of views).
            pbolle pbolle added a comment -

            Yes this project contains 38 Maven Projects. That there is only on warning could
            be correct (The projects is very small).

            at http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/
            I can see a list of all packages (Package Statistics) with there total warnings
            or error. But in the row distribution all pictures are broken. If a try to open
            the picture I can see the following exception:

            avax.servlet.ServletException: java.util.NoSuchElementException: Package not
            found: de.jamba.utils.misc.web
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:425)
            org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369)
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
            org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369)
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
            org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:248)

            org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:352)
            org.kohsuke.stapler.Stapler.service(Stapler.java:112)
            javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:52)

            hudson.security.UnwrapSecurityExceptionFilter.doFilter(UnwrapSecurityExceptionFilter.java:28)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:166)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:271)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:135)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:173)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249)

            hudson.security.HttpSessionContextIntegrationFilter2.doFilter(HttpSessionContextIntegrationFilter2.java:42)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
            hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:44)
            hudson.security.HudsonFilter.doFilter(HudsonFilter.java:85)

            org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
            root cause
            java.util.NoSuchElementException: Package not found: de.jamba.utils.misc.web

            hudson.plugins.findbugs.util.model.MavenModule.getPackage(MavenModule.java:109)

            hudson.plugins.findbugs.FindBugsResult.doPackageStatistics(FindBugsResult.java:651)
            sun.reflect.GeneratedMethodAccessor1552.invoke(Unknown Source)

            sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            java.lang.reflect.Method.invoke(Method.java:585)
            org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:103)
            org.kohsuke.stapler.Function.bindAndinvoke(Function.java:57)
            org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:69)

            org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
            org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369)
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
            org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369)
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
            org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:248)

            org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:416)
            org.kohsuke.stapler.Stapler.invoke(Stapler.java:352)
            org.kohsuke.stapler.Stapler.service(Stapler.java:112)
            javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:52)

            hudson.security.UnwrapSecurityExceptionFilter.doFilter(UnwrapSecurityExceptionFilter.java:28)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:166)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:271)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:135)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:173)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)

            org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249)

            hudson.security.HttpSessionContextIntegrationFilter2.doFilter(HttpSessionContextIntegrationFilter2.java:42)

            hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55)
            hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:44)
            hudson.security.HudsonFilter.doFilter(HudsonFilter.java:85)

            org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)

            pbolle pbolle added a comment - Yes this project contains 38 Maven Projects. That there is only on warning could be correct (The projects is very small). at http://server/hudson/job/smsservice-doc-HEAD/10/findbugsResult/ I can see a list of all packages (Package Statistics) with there total warnings or error. But in the row distribution all pictures are broken. If a try to open the picture I can see the following exception: avax.servlet.ServletException: java.util.NoSuchElementException: Package not found: de.jamba.utils.misc.web org.kohsuke.stapler.Stapler.invoke(Stapler.java:425) org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369) org.kohsuke.stapler.Stapler.invoke(Stapler.java:416) org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369) org.kohsuke.stapler.Stapler.invoke(Stapler.java:416) org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:248) org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30) org.kohsuke.stapler.Stapler.invoke(Stapler.java:416) org.kohsuke.stapler.Stapler.invoke(Stapler.java:352) org.kohsuke.stapler.Stapler.service(Stapler.java:112) javax.servlet.http.HttpServlet.service(HttpServlet.java:803) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:52) hudson.security.UnwrapSecurityExceptionFilter.doFilter(UnwrapSecurityExceptionFilter.java:28) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:166) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:271) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:135) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:173) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249) hudson.security.HttpSessionContextIntegrationFilter2.doFilter(HttpSessionContextIntegrationFilter2.java:42) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:44) hudson.security.HudsonFilter.doFilter(HudsonFilter.java:85) org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96) root cause java.util.NoSuchElementException: Package not found: de.jamba.utils.misc.web hudson.plugins.findbugs.util.model.MavenModule.getPackage(MavenModule.java:109) hudson.plugins.findbugs.FindBugsResult.doPackageStatistics(FindBugsResult.java:651) sun.reflect.GeneratedMethodAccessor1552.invoke(Unknown Source) sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) java.lang.reflect.Method.invoke(Method.java:585) org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:103) org.kohsuke.stapler.Function.bindAndinvoke(Function.java:57) org.kohsuke.stapler.MetaClass$1.doDispatch(MetaClass.java:69) org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30) org.kohsuke.stapler.Stapler.invoke(Stapler.java:416) org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369) org.kohsuke.stapler.Stapler.invoke(Stapler.java:416) org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:369) org.kohsuke.stapler.Stapler.invoke(Stapler.java:416) org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:248) org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30) org.kohsuke.stapler.Stapler.invoke(Stapler.java:416) org.kohsuke.stapler.Stapler.invoke(Stapler.java:352) org.kohsuke.stapler.Stapler.service(Stapler.java:112) javax.servlet.http.HttpServlet.service(HttpServlet.java:803) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:52) hudson.security.UnwrapSecurityExceptionFilter.doFilter(UnwrapSecurityExceptionFilter.java:28) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:166) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:271) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:135) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:173) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249) hudson.security.HttpSessionContextIntegrationFilter2.doFilter(HttpSessionContextIntegrationFilter2.java:42) hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:55) hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:44) hudson.security.HudsonFilter.doFilter(HudsonFilter.java:85) org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
            drulli Ulli Hafner added a comment -

            Hmm, that is totally strange. Why do you see several packages if you just have
            one warning in a single package? Could you please attach the build log? Is the
            attached findbugs.xml the only findbugs file in your workspace?

            Do you use the same package names in different maven modules?

            Could you please attach the file findbugs-warnings.xml in the builds folder of
            your project?

            drulli Ulli Hafner added a comment - Hmm, that is totally strange. Why do you see several packages if you just have one warning in a single package? Could you please attach the build log? Is the attached findbugs.xml the only findbugs file in your workspace? Do you use the same package names in different maven modules? Could you please attach the file findbugs-warnings.xml in the builds folder of your project?
            pbolle pbolle added a comment -

            Thank you for the fast response.
            We have many warnings in the packages but in one project we have only one
            warning. The most projects contains a findbugs.xml.
            By the way we are using a free style project to build our maven project.
            I can't find a findbugs-warinigs.xml in our project.
            I need a approval of my boss to send the log file. In the case of a problem the
            only possibility would be to create a own example project.

            pbolle pbolle added a comment - Thank you for the fast response. We have many warnings in the packages but in one project we have only one warning. The most projects contains a findbugs.xml. By the way we are using a free style project to build our maven project. I can't find a findbugs-warinigs.xml in our project. I need a approval of my boss to send the log file. In the case of a problem the only possibility would be to create a own example project.
            drulli Ulli Hafner added a comment -

            The findbugs-warnings.xml file should be in the folder:
            server/hudson/job/smsservice-doc-HEAD/builds/[build date]/findbugs-warnings.xml.

            Would be cool if you could attach at least this file...

            drulli Ulli Hafner added a comment - The findbugs-warnings.xml file should be in the folder: server/hudson/job/smsservice-doc-HEAD/builds/ [build date] /findbugs-warnings.xml. Would be cool if you could attach at least this file...
            pbolle pbolle added a comment -

            Created an attachment (id=236)
            findbugs-warnings.xml

            pbolle pbolle added a comment - Created an attachment (id=236) findbugs-warnings.xml
            drulli Ulli Hafner added a comment -

            Ok, I managed it to reproduce the problem. No further input needed. Fix will
            follow soon...

            drulli Ulli Hafner added a comment - Ok, I managed it to reproduce the problem. No further input needed. Fix will follow soon...
            drulli Ulli Hafner added a comment -

            Fixed in HEAD.

            Note: If two pom.xml files use the same <name> property then now the module name
            is made unique using a counter.

            drulli Ulli Hafner added a comment - Fixed in HEAD. Note: If two pom.xml files use the same <name> property then now the module name is made unique using a counter.
            drulli Ulli Hafner made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            abayer Andrew Bayer made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 131633 ] JNJira + In-Review [ 200818 ]

            People

              drulli Ulli Hafner
              pbolle pbolle
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: