Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16104

Build Failure Analyzer: Ugly output from plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      With release 1.3.0:

      02:14:18 Notifying upstream projects of job completion
      02:14:18 Finished: FAILURE
      [8mha:AAAAdB+LCAAAAAAAAABb85aBtbiIQSOjNKU4P0+vIKc0PTOvWK8kMze1uCQxtyC1SC8ExvbLL0llgABGJgZGLwaB3MycnMzi4My85FTXgvzkjIoiBimoScn5ecX5Oal6zhAaVS9DRQGQtm7flp8HAPhU/CWBAAAA[0mStarted by timer
      [8mha:AAAAdB+LCAAAAAAAAABb85aBtbiIQSOjNKU4P0+vIKc0PTOvWK8kMze1uCQxtyC1SC8ExvbLL0llgABGJgZGLwaB3MycnMzi4My85FTXgvzkjIoiBimoScn5ecX5Oal6zhAaVS9DRQGQtm7fNu0QAM/h4j+BAAAA[0mBuilding on master
      [8mha:AAAAdB+LCAAAAAAAAABb85aBtbiIQSOjNKU4P0+vIKc0PTOvWK8kMze1uCQxtyC1SC8ExvbLL0llgABGJgZGLwaB3MycnMzi4My85FTXgvzkjIoiBimoScn5ecX5Oal6zhAaVS9DRQGQtm7fNu0QAM/h4j+BAAAA[0mNo emails were triggered.

        Attachments

          Activity

          obo Oliver Bolte created issue -
          obo Oliver Bolte made changes -
          Field Original Value New Value
          Summary Build Failure Analyzer Build Failure Analyzer: Ugly output from plugin
          stevengbrown Steven G Brown added a comment -

          Not a Timestamper bug. Removed "timestamper" from the Components field.

          This bug appears to be caused by the way the Build Failure Analyzer plugin handles console notes. The Timestamper plugin (prior to version 1.4 only) inserted console notes, but so do other plugins and Jenkins itself.

          I was able to reproduce this with Jenkins 1.495 and only the Build Failure Analyzer plugin installed:

          • Install Build Failure Analyzer 1.3.0 and dependencies.
          • Create a new free-style build.
          • Add an Execute Script build step (I was running Linux):
            There are 42 checkstyle errors.
            exit 1
            
          • Add the Checkstyle Error cause as described on the Build Failure Analyser wiki page.
          • Run the build and inspect the console log.
          stevengbrown Steven G Brown made changes -
          Component/s timestamper [ 15749 ]
          jswager1 Jason Swager added a comment -

          Also experiencing this problem. Finding that it occurs in a couple situations:
          1) If the build if failed due to a timeout (Timeout plugin), this reliably seems to appear.
          2) An exception is generated in the Email-Ext plugin, this will often appear.

          t_westling Tomas Westling added a comment -

          Fixed in fd6d360840afec3cae00b1ded8f7b84b9fcdc295

          t_westling Tomas Westling added a comment -

          Released in 1.4.0

          t_westling Tomas Westling made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 146908 ] JNJira + In-Review [ 192135 ]

            People

            Assignee:
            t_westling Tomas Westling
            Reporter:
            obo Oliver Bolte
            Votes:
            1 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: