Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16206

Upgrade to Apache Commons Codec 1.7

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      All supported environments.
    • Similar Issues:

      Description

      There is a nasty bug in Apache Commons Codec 1.4 reported at https://issues.apache.org/jira/browse/CODEC-89 that is preventing a custom plugin to work.

      I've tried switching to the "plugin-first" strategy but faced more problems, specially because the plugin uses JAXB.

      Please evaluate upgrading.

        Attachments

          Issue Links

            Activity

            fribeiro Fernando Ribeiro created issue -
            Show
            sogabe sogabe added a comment - fixed in https://github.com/jenkinsci/jenkins/commit/b88c996d19806abcc0c9c1c605359eddb23738f5
            sogabe sogabe made changes -
            Field Original Value New Value
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            marco_rothe Marco Rothe made changes -
            Link This issue is related to JENKINS-16554 [ JENKINS-16554 ]
            Hide
            marco_rothe Marco Rothe added a comment -

            The upgrade breaks the compatibility with JDK5 (see JENKINS-16554).
            So please of Commons Codec 1.6 if achievable.

            Show
            marco_rothe Marco Rothe added a comment - The upgrade breaks the compatibility with JDK5 (see JENKINS-16554 ). So please of Commons Codec 1.6 if achievable.
            marco_rothe Marco Rothe made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            Hide
            kutzi kutzi added a comment -

            1.6 should be fine as the Commons Codec bug is reported to be fixed in 1.5

            Show
            kutzi kutzi added a comment - 1.6 should be fine as the Commons Codec bug is reported to be fixed in 1.5
            Hide
            fribeiro Fernando Ribeiro added a comment -

            I am fine with 1.6 as well.

            Show
            fribeiro Fernando Ribeiro added a comment - I am fine with 1.6 as well.
            Hide
            kutzi kutzi added a comment -

            Downgraded to codec 1.6

            Show
            kutzi kutzi added a comment - Downgraded to codec 1.6
            kutzi kutzi made changes -
            Resolution Fixed [ 1 ]
            Status Reopened [ 4 ] Resolved [ 5 ]
            fribeiro Fernando Ribeiro made changes -
            Description There is a nasty bug in Apache Commons Codec 1.4 reported https://issues.apache.org/jira/browse/CODEC-89 that is preventing a custom plugin to work.

            I've tried switching to the "plugin-first" strategy but faced more problems, specially because the plugin uses JAXB.

            Please evaluate upgrading.
            There is a nasty bug in Apache Commons Codec 1.4 reported at https://issues.apache.org/jira/browse/CODEC-89 that is preventing a custom plugin to work.

            I've tried switching to the "plugin-first" strategy but faced more problems, specially because the plugin uses JAXB.

            Please evaluate upgrading.
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 147019 ] JNJira + In-Review [ 192195 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              fribeiro Fernando Ribeiro
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: