Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16285

exception during uploading big files to a CIFS share

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Fixed
    • None
    • Ubuntu 11 32-bit Desktop - master, Ubuntu 12 64-bit Server - slave

    Description

      03:28:05 CIFS: Connecting from host [<slave hostname>]
      03:28:05 CIFS: Connecting with configuration [<CIFS config name>] ...
      03:28:05 CIFS: Removing WINS from name resolution
      03:28:05 CIFS: Setting response timeout [30,000]
      03:28:05 CIFS: Setting socket timeout [35,000]
      03:30:40 CIFS: mkdir [smb://******@<hostname><path>/<filename>.war]
      03:33:10 CIFS: copy [smb://******@<hostname><path>/<filename>.war]
      03:59:16 CIFS: Disconnecting configuration [<CIFS config name>] ...
      03:59:16 ERROR: Exception when publishing, exception message [The handle is invalid.]
      03:59:16 Build step 'Send files to a windows share' changed build result to UNSTABLE

      Attachments

        Issue Links

          Activity

            For your information, all publish-over-cifs component type JENKINS issues related to the Publish Over CIFS plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues

            Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues/34
            And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-cifs-plugin/issues?q=%22JENKINS-16285%22

            (Note: this is an automated bulk comment)

            gmcdonald Gavin McDonald added a comment - For your information, all publish-over-cifs component type JENKINS issues related to the Publish Over CIFS plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues/34 And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-cifs-plugin/issues?q=%22JENKINS-16285%22 (Note: this is an automated bulk comment)
            slide_o_mix Alex Earl added a comment -

            Fixed in 0.10

            slide_o_mix Alex Earl added a comment - Fixed in 0.10
            slide_o_mix Alex Earl added a comment -

            I tested some updates I made recently with some 500MB files and they transferred correctly, so I am thinking this may be resolved.

            slide_o_mix Alex Earl added a comment - I tested some updates I made recently with some 500MB files and they transferred correctly, so I am thinking this may be resolved.
            danielbeck Daniel Beck added a comment -

            Assuming this is Publish over CIFS plugin.

            danielbeck Daniel Beck added a comment - Assuming this is Publish over CIFS plugin.

            This occurs on osx as well while publishing 2 files of 50MB & 20MB.

            Nov 23, 2013 3:21:51 PM jenkins.plugins.publish_over.BPInstanceConfig perform
            WARNING: An exception was caught when invoking perform
            jenkins.plugins.publish_over.BapPublisherException: Exception when publishing, exception message [The handle is invalid.]
                    at jenkins.plugins.publish_over.BPCallablePublisher.invoke(BPCallablePublisher.java:68)
                    at jenkins.plugins.publish_over.BPCallablePublisher.invoke(BPCallablePublisher.java:37)
                    at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2425)
                    at hudson.remoting.UserRequest.perform(UserRequest.java:118)
                    at hudson.remoting.UserRequest.perform(UserRequest.java:48)
                    at hudson.remoting.Request$2.run(Request.java:326)
                    at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
                    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
                    at java.util.concurrent.FutureTask.run(FutureTask.java:166)
                    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
                    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
                    at hudson.remoting.Engine$1$1.run(Engine.java:63)
                    at java.lang.Thread.run(Thread.java:724)
            Caused by: jcifs.smb.SmbException: The handle is invalid.
                    at jcifs.smb.SmbTransport.checkStatus(SmbTransport.java:563)
                    at jcifs.smb.SmbTransport.send(SmbTransport.java:664)
                    at jcifs.smb.SmbSession.send(SmbSession.java:238)
                    at jcifs.smb.SmbTree.send(SmbTree.java:119)
                    at jcifs.smb.SmbFile.send(SmbFile.java:775)
                    at jcifs.smb.SmbFileOutputStream.writeDirect(SmbFileOutputStream.java:245)
                    at jcifs.smb.SmbFileOutputStream.write(SmbFileOutputStream.java:216)
                    at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1026)
                    at org.apache.commons.io.IOUtils.copy(IOUtils.java:999)
                    at jenkins.plugins.publish_over_cifs.CifsClient.transferFile(CifsClient.java:105)
                    at jenkins.plugins.publish_over_cifs.CifsClient.transferFile(CifsClient.java:39)
                    at jenkins.plugins.publish_over.BPTransfer.transferFile(BPTransfer.java:172)
                    at jenkins.plugins.publish_over.BPTransfer.transfer(BPTransfer.java:162)
                    at jenkins.plugins.publish_over.BapPublisher.perform(BapPublisher.java:146)
                    at jenkins.plugins.publish_over_cifs.CifsPublisher.perform(CifsPublisher.java:60)
                    at jenkins.plugins.publish_over.BPCallablePublisher.invoke(BPCallablePublisher.java:64)
                    ... 12 more
            
            Nov 23, 2013 7:37:00 PM hudson.model.AsyncPeriodicWork$1 run
            

            This has been preventing us from using the plugin.

            gardner Gardner Bickford added a comment - This occurs on osx as well while publishing 2 files of 50MB & 20MB. Nov 23, 2013 3:21:51 PM jenkins.plugins.publish_over.BPInstanceConfig perform WARNING: An exception was caught when invoking perform jenkins.plugins.publish_over.BapPublisherException: Exception when publishing, exception message [The handle is invalid.] at jenkins.plugins.publish_over.BPCallablePublisher.invoke(BPCallablePublisher.java:68) at jenkins.plugins.publish_over.BPCallablePublisher.invoke(BPCallablePublisher.java:37) at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2425) at hudson.remoting.UserRequest.perform(UserRequest.java:118) at hudson.remoting.UserRequest.perform(UserRequest.java:48) at hudson.remoting.Request$2.run(Request.java:326) at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) at java.util.concurrent.FutureTask.run(FutureTask.java:166) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at hudson.remoting.Engine$1$1.run(Engine.java:63) at java.lang. Thread .run( Thread .java:724) Caused by: jcifs.smb.SmbException: The handle is invalid. at jcifs.smb.SmbTransport.checkStatus(SmbTransport.java:563) at jcifs.smb.SmbTransport.send(SmbTransport.java:664) at jcifs.smb.SmbSession.send(SmbSession.java:238) at jcifs.smb.SmbTree.send(SmbTree.java:119) at jcifs.smb.SmbFile.send(SmbFile.java:775) at jcifs.smb.SmbFileOutputStream.writeDirect(SmbFileOutputStream.java:245) at jcifs.smb.SmbFileOutputStream.write(SmbFileOutputStream.java:216) at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1026) at org.apache.commons.io.IOUtils.copy(IOUtils.java:999) at jenkins.plugins.publish_over_cifs.CifsClient.transferFile(CifsClient.java:105) at jenkins.plugins.publish_over_cifs.CifsClient.transferFile(CifsClient.java:39) at jenkins.plugins.publish_over.BPTransfer.transferFile(BPTransfer.java:172) at jenkins.plugins.publish_over.BPTransfer.transfer(BPTransfer.java:162) at jenkins.plugins.publish_over.BapPublisher.perform(BapPublisher.java:146) at jenkins.plugins.publish_over_cifs.CifsPublisher.perform(CifsPublisher.java:60) at jenkins.plugins.publish_over.BPCallablePublisher.invoke(BPCallablePublisher.java:64) ... 12 more Nov 23, 2013 7:37:00 PM hudson.model.AsyncPeriodicWork$1 run This has been preventing us from using the plugin.

            Could you please share the status of this bug.
            file of size 1.17 GB copy by jenkins slave ubuntu 10.04 64 bit to cifs location failed.

            hiteswar_kumar hiteswar kumar added a comment - Could you please share the status of this bug. file of size 1.17 GB copy by jenkins slave ubuntu 10.04 64 bit to cifs location failed.
            aj2 aj2 added a comment -

            Also saw this bug on Ubuntu 10.04 64-bit machine running both master and slave. It would copy about 5MB of a 28MB file before failing. The issue went away by rebooting Jenkins

            aj2 aj2 added a comment - Also saw this bug on Ubuntu 10.04 64-bit machine running both master and slave. It would copy about 5MB of a 28MB file before failing. The issue went away by rebooting Jenkins

            People

              slide_o_mix Alex Earl
              calbooks Antuan Kappa
              Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: