Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16540

NPE when Job finishes after taking Slave offline

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • core
    • Windows 7 64 Bit/2008 Server R2

    Description

      When taking a slave offline while jobs are running I get the following NPE (I am not sure if this occurs because of fingerprinting because I have another NPE where it does not occur):

      11:24:51 Recording fingerprints
      11:24:51 Looks like the node went offline during the build. Check the slave log for the details.FATAL: null
      11:24:51 java.lang.NullPointerException
      11:24:51 at hudson.plugins.timestamper.TimestampFormatter.<init>(TimestampFormatter.java:71)
      11:24:51 at hudson.plugins.timestamper.TimestamperConfig$1.get(TimestamperConfig.java:59)
      11:24:51 at hudson.plugins.timestamper.TimestamperConfig$1.get(TimestamperConfig.java:54)
      11:24:51 at hudson.plugins.timestamper.TimestamperConfig.formatter(TimestamperConfig.java:148)
      11:24:51 at hudson.plugins.timestamper.annotator.TimestampAnnotatorFactory.newInstance(TimestampAnnotatorFactory.java:51)
      11:24:51 at hudson.console.ConsoleAnnotator._for(ConsoleAnnotator.java:143)
      11:24:51 at hudson.console.ConsoleAnnotator.initial(ConsoleAnnotator.java:133)
      11:24:51 at hudson.console.AnnotatedLargeText.createAnnotator(AnnotatedLargeText.java:140)
      11:24:51 at hudson.console.AnnotatedLargeText.writeHtmlTo(AnnotatedLargeText.java:157)
      11:24:51 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:605)
      11:24:51 at hudson.model.Run.execute(Run.java:1557)
      11:24:51 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      11:24:51 at hudson.model.ResourceController.execute(ResourceController.java:88)
      11:24:51 at hudson.model.Executor.run(Executor.java:236)

      Here is another one for a test job:
      11:23:29 Looks like the node went offline during the build. Check the slave log for the details.FATAL: null
      11:23:29 java.lang.NullPointerException
      11:23:29 at hudson.plugins.timestamper.TimestampFormatter.<init>(TimestampFormatter.java:71)
      11:23:29 at hudson.plugins.timestamper.TimestamperConfig$1.get(TimestamperConfig.java:59)
      11:23:29 at hudson.plugins.timestamper.TimestamperConfig$1.get(TimestamperConfig.java:54)
      11:23:29 at hudson.plugins.timestamper.TimestamperConfig.formatter(TimestamperConfig.java:148)
      11:23:29 at hudson.plugins.timestamper.annotator.TimestampAnnotatorFactory.newInstance(TimestampAnnotatorFactory.java:51)
      11:23:29 at hudson.console.ConsoleAnnotator._for(ConsoleAnnotator.java:143)
      11:23:29 at hudson.console.ConsoleAnnotator.initial(ConsoleAnnotator.java:133)
      11:23:29 at hudson.console.AnnotatedLargeText.createAnnotator(AnnotatedLargeText.java:140)
      11:23:29 at hudson.console.AnnotatedLargeText.writeHtmlTo(AnnotatedLargeText.java:157)
      11:23:29 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:605)
      11:23:29 at hudson.model.Run.execute(Run.java:1557)
      11:23:29 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      11:23:29 at hudson.model.ResourceController.execute(ResourceController.java:88)
      11:23:29 at hudson.model.Executor.run(Executor.java:236)

      Attachments

        Issue Links

          Activity

            bruce Dirk Kuypers created issue -
            stevengbrown Steven G Brown made changes -
            Field Original Value New Value
            Assignee stevengbrown [ stevengbrown ]
            stevengbrown Steven G Brown made changes -
            Link This issue duplicates JENKINS-16778 [ JENKINS-16778 ]

            Resolved as a duplicate of JENKINS-16778.

            stevengbrown Steven G Brown added a comment - Resolved as a duplicate of JENKINS-16778 .
            stevengbrown Steven G Brown made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            stevengbrown Steven G Brown made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 147363 ] JNJira + In-Review [ 206368 ]

            People

              stevengbrown Steven G Brown
              bruce Dirk Kuypers
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: