Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-16898

Testlink plugin exception setting status with TestNG Result Seeker

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • testlink-plugin
    • None
    • Jenkins 1.502, TestLink plugin 3.1.8 installed on Centos 6.3
      TestLink 1.9.5 with MySQL on Centos 6.3

    Description

      When using the Jenkins TestLink Plug-in Tutorial, I got a stack dump and the end of the test run (see attached). I tried this with TestLink 1.9.4 and 1.9.5 but got the same error.
      I mostly stayed with the tutorial, except that I used GIT to load the source into the project and automatically loaded maven to do the build.

      Attachments

        Activity

          jjrodgers313 Jeff Rodgers created issue -

          Hi @Jeff,

          Can you confirm if your TestLink execution statuses have been customized? The plug-in works with the default statuses from TestLink (p => passed). The message returned from the server indicates that either the 'p' status is not available or was changes, or that there's something reaaally out of the way in the plug-in or in one of its libraries

          Thanks!
          Bruno

          kinow Bruno P. Kinoshita added a comment - Hi @Jeff, Can you confirm if your TestLink execution statuses have been customized? The plug-in works with the default statuses from TestLink (p => passed). The message returned from the server indicates that either the 'p' status is not available or was changes, or that there's something reaaally out of the way in the plug-in or in one of its libraries Thanks! Bruno
          kinow Bruno P. Kinoshita made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]
          kinow Bruno P. Kinoshita made changes -
          Priority Major [ 3 ] Minor [ 4 ]
          jjrodgers313 Jeff Rodgers added a comment -

          Bruno,

          I did not change any of the execution statuses (I didn't know you could do that). Is is possible that the Tutorial changed something? Where would I look to see the list of execution status types?

          jjrodgers313 Jeff Rodgers added a comment - Bruno, I did not change any of the execution statuses (I didn't know you could do that). Is is possible that the Tutorial changed something? Where would I look to see the list of execution status types?

          Hi Jeff,

          http://www.teamst.org/forum/viewtopic.php?f=9&t=1710

          While you check if you have any custom status, I'll prepare a test project, with TL 1.9.6 (sorry, I now have only the latest version), Jenkins TestLink Plug-in (dev version, that'll be released on Tuesday), and TestNG.

          Any special characteristics in your TestNG tests?

          Thanks!

          kinow Bruno P. Kinoshita added a comment - Hi Jeff, http://www.teamst.org/forum/viewtopic.php?f=9&t=1710 While you check if you have any custom status, I'll prepare a test project, with TL 1.9.6 (sorry, I now have only the latest version), Jenkins TestLink Plug-in (dev version, that'll be released on Tuesday), and TestNG. Any special characteristics in your TestNG tests? Thanks!

          Hi Jeff,

          I just tested a simple integration. I'll attach a sample project, and some screen shots. I'm sending these files to another user that was having trouble setting up similar integration.

          It uses TestNG, Java, Maven, TL 1.9.6 and Jenkins+plugin. I believe it will be helpful. I'm cutting a new release Tuesday night (-3GMT), so if you find any bug and could report before that, I'll be happy to include it in this release (in case we can fix the issue before that).

          Many thanks! Bruno

          kinow Bruno P. Kinoshita added a comment - Hi Jeff, I just tested a simple integration. I'll attach a sample project, and some screen shots. I'm sending these files to another user that was having trouble setting up similar integration. It uses TestNG, Java, Maven, TL 1.9.6 and Jenkins+plugin. I believe it will be helpful. I'm cutting a new release Tuesday night (-3GMT), so if you find any bug and could report before that, I'll be happy to include it in this release (in case we can fix the issue before that). Many thanks! Bruno

          Screen Shots (including TL and Jenkins)

          kinow Bruno P. Kinoshita added a comment - Screen Shots (including TL and Jenkins)
          kinow Bruno P. Kinoshita made changes -
          Attachment attachments.zip [ 23418 ]

          Sample project. Java project, built with Maven 3.0.5. Dependencies: JSoup and TestNG. Produces testng-results.xml, used in TL result seeking strategy.

          kinow Bruno P. Kinoshita added a comment - Sample project. Java project, built with Maven 3.0.5. Dependencies: JSoup and TestNG. Produces testng-results.xml, used in TL result seeking strategy.
          kinow Bruno P. Kinoshita made changes -
          Attachment yahoonews-test.zip [ 23419 ]
          kinow Bruno P. Kinoshita made changes -
          Status In Progress [ 3 ] Open [ 1 ]
          jjrodgers313 Jeff Rodgers added a comment -

          I'm beginning to think something may have gone wrong in upgrading from 1.9.3 -> 1.9.4 -> 1.9.5. I'm going to try this with a clean install. BTW, I am only using the test project from your tutorial "Jenkins TestLink Plug-in Tutorial" at https://github.com/tupilabs/jenkins-testlink-plugin-tutorial so I would assume that would suffice as an example.

          jjrodgers313 Jeff Rodgers added a comment - I'm beginning to think something may have gone wrong in upgrading from 1.9.3 -> 1.9.4 -> 1.9.5. I'm going to try this with a clean install. BTW, I am only using the test project from your tutorial "Jenkins TestLink Plug-in Tutorial" at https://github.com/tupilabs/jenkins-testlink-plugin-tutorial so I would assume that would suffice as an example.

          Hi Jeff

          >I'm beginning to think something may have gone wrong in upgrading from 1.9.3 -> 1.9.4 -> 1.9.5. I'm going to try this with a clean install.

          Cool, let me know if you find anything new. I'll delay the release a few hours, but will release 3.3 within hours.

          >BTW, I am only using the test project from your tutorial "Jenkins TestLink Plug-in Tutorial" at https://github.com/tupilabs/jenkins-testlink-plugin-tutorial so I would assume that would suffice as an example.

          Indeed, that suffices as an example. I sent the other example as I was working with another user on similar issue (but his was simply a job configuration issue).

          Thank you!

          kinow Bruno P. Kinoshita added a comment - Hi Jeff >I'm beginning to think something may have gone wrong in upgrading from 1.9.3 -> 1.9.4 -> 1.9.5. I'm going to try this with a clean install. Cool, let me know if you find anything new. I'll delay the release a few hours, but will release 3.3 within hours. >BTW, I am only using the test project from your tutorial "Jenkins TestLink Plug-in Tutorial" at https://github.com/tupilabs/jenkins-testlink-plugin-tutorial so I would assume that would suffice as an example. Indeed, that suffices as an example. I sent the other example as I was working with another user on similar issue (but his was simply a job configuration issue). Thank you!
          jjrodgers313 Jeff Rodgers added a comment - - edited

          I uninstalled TestLink 1.9.5 and installed 1.9.6. I also upgraded the Jenkins TestLink plugin to 3.2. I now get the following error trying to run the tutorial example:

          Started by user anonymous
          [EnvInject] - Loading node environment variables.
          Building on master in workspace /home/jenkins/workspace/TestlinkPrototype
          Checkout:TestlinkPrototype / /home/jenkins/workspace/TestlinkPrototype - hudson.remoting.LocalChannel@6c892cb5
          Using strategy: Default
          Last Built Revision: Revision 1462fa2ef862adbba0abd652eab83bada2fb9474 (origin/master, origin/HEAD)
          Fetching changes from 1 remote Git repository
          Fetching upstream changes from origin
          Commencing build of Revision 1462fa2ef862adbba0abd652eab83bada2fb9474 (origin/HEAD)
          Checking out Revision 1462fa2ef862adbba0abd652eab83bada2fb9474 (origin/HEAD)
          [EnvInject] - Executing scripts and injecting environment variables after the SCM step.
          Preparing TestLink client API.
          Using TestLink URL: http://coltrane.aus.vbridges.com/testlink/lib/api/xmlrpc.php

          FATAL: java.util.HashMap cannot be cast to [Ljava.lang.Object;
          java.lang.ClassCastException: java.util.HashMap cannot be cast to [Ljava.lang.Object;
          at br.eti.kinoshita.testlinkjavaapi.util.Util.castToArray(Util.java:566)
          at br.eti.kinoshita.testlinkjavaapi.TestProjectService.getTestProjectByName(TestProjectService.java:111)
          at br.eti.kinoshita.testlinkjavaapi.TestLinkAPI.getTestProjectByName(TestLinkAPI.java:438)
          at hudson.plugins.testlink.TestLinkBuilder.getTestLinkSite(TestLinkBuilder.java:246)
          at hudson.plugins.testlink.TestLinkBuilder.perform(TestLinkBuilder.java:134)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:798)
          at hudson.model.Build$BuildExecution.build(Build.java:199)
          at hudson.model.Build$BuildExecution.doRun(Build.java:160)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:580)
          at hudson.model.Run.execute(Run.java:1575)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:237)

          jjrodgers313 Jeff Rodgers added a comment - - edited I uninstalled TestLink 1.9.5 and installed 1.9.6. I also upgraded the Jenkins TestLink plugin to 3.2. I now get the following error trying to run the tutorial example: Started by user anonymous [EnvInject] - Loading node environment variables. Building on master in workspace /home/jenkins/workspace/TestlinkPrototype Checkout:TestlinkPrototype / /home/jenkins/workspace/TestlinkPrototype - hudson.remoting.LocalChannel@6c892cb5 Using strategy: Default Last Built Revision: Revision 1462fa2ef862adbba0abd652eab83bada2fb9474 (origin/master, origin/HEAD) Fetching changes from 1 remote Git repository Fetching upstream changes from origin Commencing build of Revision 1462fa2ef862adbba0abd652eab83bada2fb9474 (origin/HEAD) Checking out Revision 1462fa2ef862adbba0abd652eab83bada2fb9474 (origin/HEAD) [EnvInject] - Executing scripts and injecting environment variables after the SCM step. Preparing TestLink client API. Using TestLink URL: http://coltrane.aus.vbridges.com/testlink/lib/api/xmlrpc.php FATAL: java.util.HashMap cannot be cast to [Ljava.lang.Object; java.lang.ClassCastException: java.util.HashMap cannot be cast to [Ljava.lang.Object; at br.eti.kinoshita.testlinkjavaapi.util.Util.castToArray(Util.java:566) at br.eti.kinoshita.testlinkjavaapi.TestProjectService.getTestProjectByName(TestProjectService.java:111) at br.eti.kinoshita.testlinkjavaapi.TestLinkAPI.getTestProjectByName(TestLinkAPI.java:438) at hudson.plugins.testlink.TestLinkBuilder.getTestLinkSite(TestLinkBuilder.java:246) at hudson.plugins.testlink.TestLinkBuilder.perform(TestLinkBuilder.java:134) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:798) at hudson.model.Build$BuildExecution.build(Build.java:199) at hudson.model.Build$BuildExecution.doRun(Build.java:160) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:580) at hudson.model.Run.execute(Run.java:1575) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:237)
          jjrodgers313 Jeff Rodgers added a comment -

          My bad, I see that issue I just posted is a duplicate of #17442.

          jjrodgers313 Jeff Rodgers added a comment - My bad, I see that issue I just posted is a duplicate of #17442.

          No worries Jeff. 3.3 just got out of my machine. It should be available in the update site in few hours. Keep an eye on @jenkins_release, and let me know if that fixes your issue, please.

          kinow Bruno P. Kinoshita added a comment - No worries Jeff. 3.3 just got out of my machine. It should be available in the update site in few hours. Keep an eye on @jenkins_release, and let me know if that fixes your issue, please.
          jjrodgers313 Jeff Rodgers added a comment -

          Fixed in version 3.3 with TestLink version 1.9.6.

          jjrodgers313 Jeff Rodgers added a comment - Fixed in version 3.3 with TestLink version 1.9.6.
          jjrodgers313 Jeff Rodgers made changes -
          Fix Version/s current [ 10162 ]
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]

          Thanks for updating the issue @Jeff!

          kinow Bruno P. Kinoshita added a comment - Thanks for updating the issue @Jeff!

          Fixed in 3.3

          kinow Bruno P. Kinoshita added a comment - Fixed in 3.3
          kinow Bruno P. Kinoshita made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 147727 ] JNJira + In-Review [ 206425 ]

          People

            kinow Bruno P. Kinoshita
            jjrodgers313 Jeff Rodgers
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: