Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17017

Exception recovery fails

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I'm seeing the error below. Unfortunately, there is no recovery here, and the trhead is stuck. I have to restart jenkins to run anew try with changed IRC settings.

      hudson.plugins.im.IMConnectionProvider$ConnectorRunnable run
      INFO: Trying to reconnect
      hudson.plugins.ircbot.v2.IRCConnection connect
      INFO: Connecting to xxxx:6667 as xxxx using charset UTF-8
      Exception in thread "IM-Reconnector-Thread" java.lang.RuntimeException: Exception encountered when writng to socket
              at org.pircbotx.OutputThread.sendRawLineNow(OutputThread.java:71)
              at org.pircbotx.PircBotX.connect(PircBotX.java:340)
              at hudson.plugins.ircbot.v2.IRCConnection.connect(IRCConnection.java:118)
              at hudson.plugins.ircbot.v2.IRCConnectionProvider.createConnection(IRCConnectionProvider.java:37)
              at hudson.plugins.im.IMConnectionProvider.create(IMConnectionProvider.java:65)
              at hudson.plugins.im.IMConnectionProvider.access$600(IMConnectionProvider.java:22)
              at hudson.plugins.im.IMConnectionProvider$ConnectorRunnable.run(IMConnectionProvider.java:183)
              at java.lang.Thread.run(Thread.java:679)
      Caused by: java.net.SocketException: Broken pipe
              at java.net.SocketOutputStream.socketWrite0(Native Method)
              at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:109)
              at java.net.SocketOutputStream.write(SocketOutputStream.java:153)
              at sun.nio.cs.StreamEncoder.writeBytes(StreamEncoder.java:220)
              at sun.nio.cs.StreamEncoder.implFlushBuffer(StreamEncoder.java:290)
              at sun.nio.cs.StreamEncoder.implFlush(StreamEncoder.java:294)
              at sun.nio.cs.StreamEncoder.flush(StreamEncoder.java:140)
              at java.io.OutputStreamWriter.flush(OutputStreamWriter.java:229)
              at java.io.BufferedWriter.flush(BufferedWriter.java:253)
              at org.pircbotx.OutputThread.sendRawLineNow(OutputThread.java:67)
              ... 7 more
      

        Attachments

          Activity

          axelh Axel Heider created issue -
          axelh Axel Heider made changes -
          Field Original Value New Value
          Link This issue is related to JENKINS-10137 [ JENKINS-10137 ]
          kutzi kutzi made changes -
          Link This issue is related to JENKINS-10137 [ JENKINS-10137 ]
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Christoph Kutzinski
          Path:
          src/main/java/hudson/plugins/ircbot/v2/IRCConnection.java
          http://jenkins-ci.org/commit/ircbot-plugin/3f3a6bd9e027a2f0a2585218dcfe5d2637ba9dda
          Log:
          [FIXED JENKINS-17017] PircBotX#connect() sometimes fails with RuntimeExcpetion - which is not exactly what the Javadoc says

          scm_issue_link SCM/JIRA link daemon made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 147847 ] JNJira + In-Review [ 192606 ]

            People

            Assignee:
            kutzi kutzi
            Reporter:
            axelh Axel Heider
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: