Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17221

"You must use POST method to trigger builds" warning message pops up preventing remote triggering of builds with parameters using wget URL http://server/job/myjob/buildWithParameters?PARAMETER=Value

    XMLWordPrintable

Details

    Description

      When trying to trigger builds remotely using the URL http://server/job/myjob/buildWithParameters?PARAMETER=Value, the following message comes up.

      You must use POST method to trigger builds. (From scripts you may instead pass a per-project authentication token, or authenticate with your API token.) If you see this page, it may be because a plugin offered a GET link; file a bug report for that plugin.
      

      There is a "Proceed" button which needs to be clicked on manually which causes (post-commit) remote triggering of builds via wget to fail.

      This problem did not exist in 1.501, onlty started to notice this issue in versions 1.503 and 1.505.

      Attachments

        Activity

          leo_ Leo Leung created issue -
          leo_ Leo Leung made changes -
          Field Original Value New Value
          Description When trying to trigger builds remotely using the URL http://server/job/myjob/buildWithParameters?PARAMETER=Value, the following message comes up.

          {noformat}
          You must use POST method to trigger builds. (From scripts you may instead pass a per-project authentication token, or authenticate with your API token.) If you see this page, it may be because a plugin offered a GET link; file a bug report for that plugin.
          {noformat}

          There is a "Proceed" button which needs to be clicked on manually which causes (post-commit) remote triggering of builds via wget to fail.
          When trying to trigger builds remotely using the URL http://server/job/myjob/buildWithParameters?PARAMETER=Value, the following message comes up.

          {noformat}
          You must use POST method to trigger builds. (From scripts you may instead pass a per-project authentication token, or authenticate with your API token.) If you see this page, it may be because a plugin offered a GET link; file a bug report for that plugin.
          {noformat}

          There is a "Proceed" button which needs to be clicked on manually which causes (post-commit) remote triggering of builds via wget to fail.

          This problem did not exist in 1.501, onlty started to notice this issue in versions 1.503 and 1.505.
          jglick Jesse Glick added a comment -

          As the message says, you must now use POST requests for things like this. Consult the documentation for wget or whatever you use. Pull requests with more emphatic/clearer messages welcome.

          jglick Jesse Glick added a comment - As the message says, you must now use POST requests for things like this. Consult the documentation for wget or whatever you use. Pull requests with more emphatic/clearer messages welcome.
          jglick Jesse Glick made changes -
          Resolution Not A Defect [ 7 ]
          Status Open [ 1 ] Resolved [ 5 ]
          leo_ Leo Leung added a comment -

          I guess the page https://wiki.jenkins-ci.org/display/JENKINS/Parameterized+Build needs to be updated since the following recommended method no longer works.

          • A build can be started just by accessing
            http://server/job/myjob/buildWithParameters?PARAMETER=Value
            

          I manged to work around the issue by using build trigger authentication tokens as the warning message suggests.

          leo_ Leo Leung added a comment - I guess the page https://wiki.jenkins-ci.org/display/JENKINS/Parameterized+Build needs to be updated since the following recommended method no longer works. A build can be started just by accessing http://server/job/myjob/buildWithParameters?PARAMETER=Value I manged to work around the issue by using build trigger authentication tokens as the warning message suggests.
          jglick Jesse Glick added a comment -

          Edited.

          jglick Jesse Glick added a comment - Edited.

          What about when clicking on the "Build Now" link and this occurs? Is that a core issue, a plugin issue, or maybe a configuration issue?

          kt Kevin Thieling added a comment - What about when clicking on the "Build Now" link and this occurs? Is that a core issue, a plugin issue, or maybe a configuration issue?
          jglick Jesse Glick added a comment -

          @kt said:

          What about when clicking on the "Build Now" link and this occurs?

          That would be a separate bug report, assuming you could reproduce from scratch in a current version of Jenkins and provide details.

          jglick Jesse Glick added a comment - @kt said: What about when clicking on the "Build Now" link and this occurs? That would be a separate bug report, assuming you could reproduce from scratch in a current version of Jenkins and provide details.
          ircbot Jenkins IRC Bot made changes -
          Component/s core [ 15593 ]
          Component/s parameters [ 15594 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 148053 ] JNJira + In-Review [ 192698 ]
          janarb Jan Wittig added a comment -

          I had the same issue as kt and found the reason: Firefox No Script Plugin deactivated Javascript and Jenkins UI without Javascript ran into the issue with Build Now. So maybe a Javascript blocked error message would help.

          janarb Jan Wittig added a comment - I had the same issue as kt and found the reason: Firefox No Script Plugin deactivated Javascript and Jenkins UI without Javascript ran into the issue with Build Now. So maybe a Javascript blocked error message would help.

          People

            Unassigned Unassigned
            leo_ Leo Leung
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: