Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-17504

TAP Plugin generates bad detail links on "tapTestReport" page

    XMLWordPrintable

Details

    Description

      (See this page for the original report of this bug in context)

      The fix for JENKINS-16971 (e8dcf5c) breaks my Jenkins TAP plugin installation. Specifically, the detail links on the http://jenkins.example.org/job/JOBNAME/BUILDNUM/tapTestReport/ page are incorrect. They should read something like http://jenkins.example.org/job/JOBNAME/BUILDNUM/tapTestReport/summary.tap-1/. Instead they read something like http://jenkins.example.org/var/lib/jenkins/jobs/JOBNAME/builds/2013-04-04_12-43-45/tap-master-files/test/mpi/summary.tap-1/. Obviously this URL is invalid and yields an HTTP 404 from the web server.
      I suspect the problem is caused by the replacement of getName() with getAbsolutePath(). Reverting commit e8dcf5c fixes the error in my otherwise clean build of 80a01b1. I made no attempt to test or understand the issue actually reported in and/or addressed by JENKINS-16971.

      Attachments

        Activity

          goodell Dave Goodell created issue -

          Hi Dave, thanks for reporting. There are some bad code that I'll have to rewrite for the next release.

          I'll plan a major release with the refactored code, and hopefully we won't have problems with regard to downloading TAP files. I know Jenkins has some built-in code that can handle that.

          kinow Bruno P. Kinoshita added a comment - Hi Dave, thanks for reporting. There are some bad code that I'll have to rewrite for the next release. I'll plan a major release with the refactored code, and hopefully we won't have problems with regard to downloading TAP files. I know Jenkins has some built-in code that can handle that.
          kinow Bruno P. Kinoshita made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]
          kinow Bruno P. Kinoshita made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]

          Code changed in jenkins
          User: Bruno P. Kinoshita
          Path:
          src/main/java/org/tap4j/plugin/AbstractTapProjectAction.java
          src/main/java/org/tap4j/plugin/TapPublisher.java
          src/main/java/org/tap4j/plugin/model/TestSetMap.java
          src/main/resources/org/tap4j/plugin/TapResult/_index.groovy
          src/main/resources/org/tap4j/plugin/TapResult/index.groovy
          src/main/resources/org/tap4j/plugin/model/TapStreamResult/body.jelly
          src/test/java/org/tap4j/plugin/issue17947/TestIssue17947.java
          src/test/java/org/tap4j/plugin/issue17947/package-info.java
          http://jenkins-ci.org/commit/tap-plugin/f1c034f74ce58591b24a1f5c5f9fd7f54bf1a675
          Log:
          [FIXED JENKINS-17504] Fix 404 bad detail links on results page

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Bruno P. Kinoshita Path: src/main/java/org/tap4j/plugin/AbstractTapProjectAction.java src/main/java/org/tap4j/plugin/TapPublisher.java src/main/java/org/tap4j/plugin/model/TestSetMap.java src/main/resources/org/tap4j/plugin/TapResult/_index.groovy src/main/resources/org/tap4j/plugin/TapResult/index.groovy src/main/resources/org/tap4j/plugin/model/TapStreamResult/body.jelly src/test/java/org/tap4j/plugin/issue17947/TestIssue17947.java src/test/java/org/tap4j/plugin/issue17947/package-info.java http://jenkins-ci.org/commit/tap-plugin/f1c034f74ce58591b24a1f5c5f9fd7f54bf1a675 Log: [FIXED JENKINS-17504] Fix 404 bad detail links on results page

          Fixed in 1.11 (should be available through the update site in the next minute/hours)

          kinow Bruno P. Kinoshita added a comment - Fixed in 1.11 (should be available through the update site in the next minute/hours)
          kinow Bruno P. Kinoshita made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

          Updating to 1.11 brought back the bad behavior Dave described in my installation.

          raffenet Ken Raffenetti added a comment - Updating to 1.11 brought back the bad behavior Dave described in my installation.

          @Ken, weird. I'll take a look tomorrow Ken. Sorry for that :-/

          kinow Bruno P. Kinoshita added a comment - @Ken, weird. I'll take a look tomorrow Ken. Sorry for that :-/

          Reopening due to regression

          kinow Bruno P. Kinoshita added a comment - Reopening due to regression
          kinow Bruno P. Kinoshita made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]

          No problem. Let me know if you need any more info. I've gone back to my custom 1.11 snapshot with the troublesome commit Dave cited git revert'ed out.

          raffenet Ken Raffenetti added a comment - No problem. Let me know if you need any more info. I've gone back to my custom 1.11 snapshot with the troublesome commit Dave cited git revert'ed out.

          Fixed on issues 18885 and 17855, with commit http://jenkins-ci.org/commit/tap-plugin/21e7af07d5ae18327eb7a2626184970a6ff1d995

          Sorry for mixing issues in the same commit, but I started working on 18885 this morning and it included this issue too.

          Cutting a new release tonight, tomorrow morning/noon you should be able to give 1.12 a try.

          Thanks!

          kinow Bruno P. Kinoshita added a comment - Fixed on issues 18885 and 17855, with commit http://jenkins-ci.org/commit/tap-plugin/21e7af07d5ae18327eb7a2626184970a6ff1d995 Sorry for mixing issues in the same commit, but I started working on 18885 this morning and it included this issue too. Cutting a new release tonight, tomorrow morning/noon you should be able to give 1.12 a try. Thanks!
          kinow Bruno P. Kinoshita made changes -
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Resolved [ 5 ]

          Fixed in 1.12

          kinow Bruno P. Kinoshita added a comment - Fixed in 1.12
          kinow Bruno P. Kinoshita made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 148683 ] JNJira + In-Review [ 206558 ]

          People

            kinow Bruno P. Kinoshita
            goodell Dave Goodell
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: