Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18080

Jenkins slave cannot connect to Master using jnlp

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: core
    • Environment:
      Master is on Debian and slave runs on windows 2008 r2k
    • Similar Issues:

      Description

      The jenkins slave counld not connect to the master. It was running well before I rebooted the slave. All The Jnlp window states is connecting to master and times out with this error I have attached poping after several retry.

        Attachments

          Activity

          bullhornrelease Bullhorn RelEng added a comment -

          I also fixed my instance of it by opening up access to the master from the slave by adding an iptables rule.

          oleg_nenashev Oleg Nenashev added a comment -

          The issue is definitely unrelated to robot-plugin.
          Changed the issue's metadata.

          @Samuel, If the issue stills open, please provide more info about Jenkins version, etc.

          bullhornrelease Bullhorn RelEng added a comment -

          I don't believe this has anything to do with robot. I see this with a linux master and windows slave, after the slave restarted itself. The connection was fine before.

          jussi_malinen Jussi Malinen added a comment -

          We dont know how or if this is related to Robot Framework plugin. We can reopen this issue if more details are provided.

          jpiironen jpiironen added a comment -

          Hi, Can you elaborate how this relates to the Robot Framework plugin?


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            wachira Samuel Kamau
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: