Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18220

Unable to find a build for artifact copy

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • copyartifact-plugin
    • None
    • Windows 2008 R2
      Jenkins 1.516
      CopyArtifact 1.27

    Description

      Executing copy artifacts against a specific build number. In this case, the project is trunk_analyzers_merge-modules and the build number is 50. The build fails as follows:
      Copied 2 artifacts from "trunk_database-clone" build number 48
      Unable to find a build for artifact copy from: trunk_analyzers_merge-modules

      This persists until the trunk_analyzers_merge-modules project page is viewed, at which point the next build will be successful:
      Copied 2 artifacts from "trunk_database-clone" build number 48
      Copied 5 artifacts from "trunk_analyzers_merge-modules" build number 50

      The same build will fail again the following day. This is happening with many jobss.

      No obvious errors in the Jenkins logs.

      Attachments

        Issue Links

          Activity

            danielbeck Daniel Beck added a comment -

            Resolving as duplicate: I had experienced this issue as well, but it went away as soon as I upgraded to a version of Jenkins that included the fix to JENKINS-19418.

            danielbeck Daniel Beck added a comment - Resolving as duplicate: I had experienced this issue as well, but it went away as soon as I upgraded to a version of Jenkins that included the fix to JENKINS-19418 .
            danielbeck Daniel Beck added a comment - - edited

            Probably duplicate of JENKINS-19418.

            danielbeck Daniel Beck added a comment - - edited Probably duplicate of JENKINS-19418 .

            Code changed in jenkins
            User: Jesse Glick
            Path:
            src/main/java/hudson/plugins/copyartifact/SpecificBuildSelector.java
            http://jenkins-ci.org/commit/copyartifact-plugin/129ce342d7207de3e87055dddb896ca0f4be1cfe
            Log:
            JENKINS-18220 Diagnostics.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Jesse Glick Path: src/main/java/hudson/plugins/copyartifact/SpecificBuildSelector.java http://jenkins-ci.org/commit/copyartifact-plugin/129ce342d7207de3e87055dddb896ca0f4be1cfe Log: JENKINS-18220 Diagnostics.
            danielbeck Daniel Beck added a comment -

            I experience a similar issue on 1.509.2 on RHEL 6.

            How do you specify the specific build number? As variable reference (e.g. $build_no) in the Copy Artifact build step (value from e.g. build parameter or env-inject), or directly as number (e.g. 123)?

            danielbeck Daniel Beck added a comment - I experience a similar issue on 1.509.2 on RHEL 6. How do you specify the specific build number? As variable reference (e.g. $ build_no ) in the Copy Artifact build step (value from e.g. build parameter or env-inject), or directly as number (e.g. 123 )?

            People

              Unassigned Unassigned
              chorn Cameron Horn
              Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: