Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1872

prepare for shutdown + logout = redirect loop

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: _unsorted
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      If you have a Hudson with authentication set up, and use 'prepare for shutdown',
      then you will go into a redirect loop if you logout. People who were not logged
      will also have problems accessing the site.

        Attachments

          Issue Links

            Activity

            huybrechts huybrechts created issue -
            kohsuke Kohsuke Kawaguchi added a comment -

            Sorry for being slow, but what's the steps to reproduce this?

            You login, click "prepare for shutdown" (then you'll be taken back to
            http://server/hudson/), then you logout from this top page?

            huybrechts huybrechts added a comment -

            Yes.

            This is on my branch, but I don' think there are any related changes there.

            huybrechts huybrechts added a comment -

            This exception is thrown while handling the request for '/'.

            org.apache.commons.jelly.JellyTagException:
            jar:file:/C:/dev/hudson-plugins/jbpm/target/work/webapp/WEB-INF/lib/hudson-core-1.222-SNAPSHOT.jar!/lib/hudson/queue.jelly:14:61:
            <j:if>
            org.acegisecurity.providers.anonymous.AnonymousAuthenticationToken@7ce960df:
            Username: anonymous; Password: [PROTECTED]; Authenticated: true; Details:
            org.acegisecurity.ui.WebAuthenticationDetails@2eb76: RemoteIpAddress: 127.0.0.1;
            SessionId: 1jpza0f2uvr4p; Granted Authorities: is missing Administer

            The problem is in queue.jelly:

            <j:if test="${h.checkPermission(app.ADMINISTER)}">
            <a href="${rootURL}/cancelQuietDown">(${%cancel})</a>
            </j:if>

            This should be hasPermission instead of checkPermission.

            Fixed in trunk.

            huybrechts huybrechts made changes -
            Field Original Value New Value
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            mindless Alan Harder added a comment -
                • Issue 1541 has been marked as a duplicate of this issue. ***
            mindless Alan Harder made changes -
            Link This issue is duplicated by JENKINS-1541 [ JENKINS-1541 ]
            mindless Alan Harder added a comment -
                • Issue 1844 has been marked as a duplicate of this issue. ***
            mindless Alan Harder made changes -
            Link This issue is duplicated by JENKINS-1844 [ JENKINS-1844 ]
            abayer Andrew Bayer made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 131945 ] JNJira + In-Review [ 201050 ]
            ircbot Jenkins IRC Bot made changes -
            Component/s _unsorted [ 19622 ]
            Component/s security [ 15508 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              huybrechts huybrechts
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: