Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18827

Build history doesn't display all available build

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Duplicate
    • core
    • None
    • jenkins v1.5.17, Java jre1.7.0_17_64, Windows 7 Enterprise SP1

    Description

      1) job config is set to keep up to 15 builds

      Issue 1: Build history displays only 1 build even though...
      Issue 2: ...on HDD are 37 builds stored and each of it has a symlink.

      That means the display does NOT show all available builds AND it does NOT remove older builds.

      Attachments

        Issue Links

          Activity

            robsimon robsimon created issue -
            jean Jean Helou added a comment -

            This seems to have the following bad side effect on continuous builds which build all git branches. The server "forgets" that the branches were already built and rebuilds everything at a huge time cost ...

            jean Jean Helou added a comment - This seems to have the following bad side effect on continuous builds which build all git branches. The server "forgets" that the branches were already built and rebuilds everything at a huge time cost ...

            do you have a picture of this? IS this the build history widget? I can see on my jenkins the widget is displaying 33 builds in its list.

            Running on
            Jenkins ver. 1.528

            martin_naughton martin naughton added a comment - do you have a picture of this? IS this the build history widget? I can see on my jenkins the widget is displaying 33 builds in its list. Running on Jenkins ver. 1.528

            what restart jenkins solve the issue? That would then be correct that it has forget about them. The number of builds in a view come from the view object.

            Picture would help clarify more

            martin_naughton martin naughton added a comment - what restart jenkins solve the issue? That would then be correct that it has forget about them. The number of builds in a view come from the view object. Picture would help clarify more
            oleg_nenashev Oleg Nenashev added a comment -

            Most probably, the issue has been caused by the job's renaming. See JENKINS-18678

            oleg_nenashev Oleg Nenashev added a comment - Most probably, the issue has been caused by the job's renaming. See JENKINS-18678
            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-18678 [ JENKINS-18678 ]
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Duplicate [ 3 ]
            Status Reopened [ 4 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 150177 ] JNJira + In-Review [ 193449 ]

            People

              Unassigned Unassigned
              robsimon robsimon
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: