Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-18849

java.lang.ClassNotFoundException: hudson.maven.AbstractMavenProject

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      RHEL
    • Similar Issues:

      Description

      I upgraded to 1.509.2. Now, the post build actions of the configure page is not displaying and giving an error 500. The Jenkins log is full of java.lang.ClassNotFoundException: hudson.maven.AbstractMavenProject.

      Screen shots and logs attached

      NOTE: I downgraded back to 1.509.1 but the error still exists.

        Attachments

          Issue Links

            Activity

            hoohaa8384 Joshua Slominski created issue -
            franciscoruiz Francisco Ruiz added a comment -

            The same error on 1.524 but apparently related to Violations plugin

            Caused by: java.lang.NoClassDefFoundError: hudson/maven/AbstractMavenProject
                  at hudson.plugins.violations.hudson.ViolationsFreestyleDescriptor.isApplicable(ViolationsFreestyleDescriptor.java:104)
                  at hudson.tasks.BuildStepDescriptor.filter(BuildStepDescriptor.java:84)
                  at hudson.Functions.getPublisherDescriptors(Functions.java:766)
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                  at java.lang.reflect.Method.invoke(Method.java:616)
            
            lekksi Aleksi Hoffman added a comment -

            I had the same error on 1.525.
            Enabling the Maven Integration plugin (maven-plugin) in Plugin manager worked as a workaround.

            franciscoruiz Francisco Ruiz added a comment -

            Enabling the Maven Integration plugin has worked for me too.

            roliver Rodney Oliver added a comment -

            +1 on enabling the Maven Integration plugin as a workaround for this issue

            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Link This issue is duplicated by JENKINS-19230 [ JENKINS-19230 ]
            oleg_nenashev Oleg Nenashev added a comment -

            The issue was in the Maven plugin, which has been decoupled from the Jenkins core (Oct 22, 2013)

            oleg_nenashev Oleg Nenashev made changes -
            Resolution Won't Fix [ 2 ]
            Status Open [ 1 ] Resolved [ 5 ]
            danielbeck Daniel Beck added a comment -

            Oleg: Actually, cause is a until just now undocumented change to plugin dependency loading in 1.524. The original of issues like this one is probably JENKINS-18922.

            oleg_nenashev Oleg Nenashev made changes -
            Resolution Won't Fix [ 2 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is related to JENKINS-18654 [ JENKINS-18654 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-18922 [ JENKINS-18922 ]
            oleg_nenashev Oleg Nenashev added a comment -

            According to JENKINS-18654, the fix has been backported to 1.509.3, but the issue has been submitted to 1.509.2-

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-18922 [ JENKINS-18922 ]
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is related to JENKINS-18922 [ JENKINS-18922 ]
            danielbeck Daniel Beck added a comment -

            Right, I checked this issue in more detail and they're only superficially the same: Due to IO problems of some kind it failed to extract the Maven Plugin (and possibly Monitor External Job), so it's not just disabled, but missing completely. The effect is the same as with a disabled plugin post-1.524.

            Fix the logged IO root cause (e.g. missing permissions), possibly deleting maven-plugin.jpi and the issue should disappear.


            More information is needed to investigate this further, like the permissions inside the plugins directory, what kind of file system, etc.

            jglick Jesse Glick made changes -
            Link This issue duplicates JENKINS-18922 [ JENKINS-18922 ]
            jglick Jesse Glick made changes -
            Link This issue is related to JENKINS-18922 [ JENKINS-18922 ]
            jglick Jesse Glick added a comment -

            Is this not just a duplicate of JENKINS-18922?

            danielbeck Daniel Beck added a comment -

            Jesse: See my previous comment. They look similar but this is a version from before the 1.524 fix or backport.

            Despite that, resolving as incomplete, as there has been no response to my comment asking for additional information.

            danielbeck Daniel Beck made changes -
            Resolution Incomplete [ 4 ]
            Status Reopened [ 4 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 150199 ] JNJira + In-Review [ 193460 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              hoohaa8384 Joshua Slominski
              Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: