Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19251

After upgrade from 1.519 to 1.526 -> NumberFormatException occurs during maven 3 build

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Fixed
    • maven-plugin

    Description

      Builds of type Maven2/3 Build.

      Started by timer
      [EnvInject] - Loading node environment variables.
      Building remotely on KO.LINUX.05 in workspace XXXx
      
      Cleaning up /var/lib/jenkins/workspace/fb_g3his.tea.wma-root_deploy/.
      
      Updating XXXXXX/wma.3.1.x-fb/wma-root at revision '2013-08-18T22:00:13.715 +0200'
      At revision 134474
      
      no change for http://XXXXXX/wma.3.1.x-fb/wma-root since the previous build
      
      Parsing POMs
      
      Downloaded artifacts..... 
      
      [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar /var/lib/jenkins/maven3-interceptor-commons.jar 48798
      Exception in thread "main" java.lang.NumberFormatException: For input string: "/var/lib/jenkins/maven3-interceptor-commons.jar"
      	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
      	at java.lang.Integer.parseInt(Integer.java:449)
      	at java.lang.Integer.parseInt(Integer.java:499)
      	at org.jvnet.hudson.maven3.agent.Maven3Main.main(Maven3Main.java:65)
      
      ERROR: Failed to launch Maven. Exit code = 1
      An attempt to send an e-mail to empty list of recipients, ignored.
      Notifying upstream projects of job completion
      Finished: FAILURE
      
      

      Other info:

      • What is funny that upgrade was done on Friday -> builds were working throught weekend without any biggers problems, on Monday this bug appears.
      • it affects about 50% of builds of most projects - undeterministic ...
        When builds passed corresponding maven line has the different numbers or arguments - without "/var/lib/jenkins/maven3-interceptor-commons.jar"
      [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar 46450
      
      • when I rollback to 1.519 its gone
      • after week once again upgraded but to 1.527 and the same bug shown
      • rollback to 1.519 helped..

      I can deliver more info just need to know what...

      Attachments

        Issue Links

          Activity

            marecki Marek Marzec created issue -
            marecki Marek Marzec made changes -
            Field Original Value New Value
            Description Started by timer
            [EnvInject] - Loading node environment variables.
            Building remotely on KO.LINUX.05 in workspace XXXx

            Cleaning up /var/lib/jenkins/workspace/fb_g3his.tea.wma-root_deploy/.

            Updating XXXXXX/wma.3.1.x-fb/wma-root at revision '2013-08-18T22:00:13.715 +0200'
            At revision 134474

            no change for http://XXXXXX/wma.3.1.x-fb/wma-root since the previous build

            Parsing POMs

            Downloaded artifacts.....

            [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar /var/lib/jenkins/maven3-interceptor-commons.jar 48798
            Exception in thread "main" java.lang.NumberFormatException: For input string: "/var/lib/jenkins/maven3-interceptor-commons.jar"
            at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
            at java.lang.Integer.parseInt(Integer.java:449)
            at java.lang.Integer.parseInt(Integer.java:499)
            at org.jvnet.hudson.maven3.agent.Maven3Main.main(Maven3Main.java:65)

            ERROR: Failed to launch Maven. Exit code = 1
            An attempt to send an e-mail to empty list of recipients, ignored.
            Notifying upstream projects of job completion
            Finished: FAILURE


            h2. Other info:

            * What is funny that upgrade was done on Friday -> builds were working throught weekend without any biggers problems, on Monday this bug appears.

            * it affects about 50% of builds of most projects - undeterministic ...


            * when I rollback to 1.519 its gone


            * after week once again upgraded but to 1.527 and the same bug shown

            * rollback to 1.519 helped..



            I can deliver more info just need to know what...


            {code}
            Started by timer
            [EnvInject] - Loading node environment variables.
            Building remotely on KO.LINUX.05 in workspace XXXx

            Cleaning up /var/lib/jenkins/workspace/fb_g3his.tea.wma-root_deploy/.

            Updating XXXXXX/wma.3.1.x-fb/wma-root at revision '2013-08-18T22:00:13.715 +0200'
            At revision 134474

            no change for http://XXXXXX/wma.3.1.x-fb/wma-root since the previous build

            Parsing POMs

            Downloaded artifacts.....

            [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar /var/lib/jenkins/maven3-interceptor-commons.jar 48798
            Exception in thread "main" java.lang.NumberFormatException: For input string: "/var/lib/jenkins/maven3-interceptor-commons.jar"
            at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
            at java.lang.Integer.parseInt(Integer.java:449)
            at java.lang.Integer.parseInt(Integer.java:499)
            at org.jvnet.hudson.maven3.agent.Maven3Main.main(Maven3Main.java:65)

            ERROR: Failed to launch Maven. Exit code = 1
            An attempt to send an e-mail to empty list of recipients, ignored.
            Notifying upstream projects of job completion
            Finished: FAILURE

            {code}
            h2. Other info:

            * What is funny that upgrade was done on Friday -> builds were working throught weekend without any biggers problems, on Monday this bug appears.

            * it affects about 50% of builds of most projects - undeterministic ...


            * when I rollback to 1.519 its gone


            * after week once again upgraded but to 1.527 and the same bug shown

            * rollback to 1.519 helped..



            I can deliver more info just need to know what...


            marecki Marek Marzec made changes -
            Description {code}
            Started by timer
            [EnvInject] - Loading node environment variables.
            Building remotely on KO.LINUX.05 in workspace XXXx

            Cleaning up /var/lib/jenkins/workspace/fb_g3his.tea.wma-root_deploy/.

            Updating XXXXXX/wma.3.1.x-fb/wma-root at revision '2013-08-18T22:00:13.715 +0200'
            At revision 134474

            no change for http://XXXXXX/wma.3.1.x-fb/wma-root since the previous build

            Parsing POMs

            Downloaded artifacts.....

            [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar /var/lib/jenkins/maven3-interceptor-commons.jar 48798
            Exception in thread "main" java.lang.NumberFormatException: For input string: "/var/lib/jenkins/maven3-interceptor-commons.jar"
            at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
            at java.lang.Integer.parseInt(Integer.java:449)
            at java.lang.Integer.parseInt(Integer.java:499)
            at org.jvnet.hudson.maven3.agent.Maven3Main.main(Maven3Main.java:65)

            ERROR: Failed to launch Maven. Exit code = 1
            An attempt to send an e-mail to empty list of recipients, ignored.
            Notifying upstream projects of job completion
            Finished: FAILURE

            {code}
            h2. Other info:

            * What is funny that upgrade was done on Friday -> builds were working throught weekend without any biggers problems, on Monday this bug appears.

            * it affects about 50% of builds of most projects - undeterministic ...


            * when I rollback to 1.519 its gone


            * after week once again upgraded but to 1.527 and the same bug shown

            * rollback to 1.519 helped..



            I can deliver more info just need to know what...


            {code}
            Started by timer
            [EnvInject] - Loading node environment variables.
            Building remotely on KO.LINUX.05 in workspace XXXx

            Cleaning up /var/lib/jenkins/workspace/fb_g3his.tea.wma-root_deploy/.

            Updating XXXXXX/wma.3.1.x-fb/wma-root at revision '2013-08-18T22:00:13.715 +0200'
            At revision 134474

            no change for http://XXXXXX/wma.3.1.x-fb/wma-root since the previous build

            Parsing POMs

            Downloaded artifacts.....

            [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar /var/lib/jenkins/maven3-interceptor-commons.jar 48798
            Exception in thread "main" java.lang.NumberFormatException: For input string: "/var/lib/jenkins/maven3-interceptor-commons.jar"
            at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
            at java.lang.Integer.parseInt(Integer.java:449)
            at java.lang.Integer.parseInt(Integer.java:499)
            at org.jvnet.hudson.maven3.agent.Maven3Main.main(Maven3Main.java:65)

            ERROR: Failed to launch Maven. Exit code = 1
            An attempt to send an e-mail to empty list of recipients, ignored.
            Notifying upstream projects of job completion
            Finished: FAILURE

            {code}
            h2. Other info:

            * What is funny that upgrade was done on Friday -> builds were working throught weekend without any biggers problems, on Monday this bug appears.

            * it affects about 50% of builds of most projects - undeterministic ...
            When builds passed corresponding maven line has the same content just different number:

            {code}
            [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar 46450
            {code}

            * when I rollback to 1.519 its gone


            * after week once again upgraded but to 1.527 and the same bug shown

            * rollback to 1.519 helped..



            I can deliver more info just need to know what...


            Summary After upgrade from 1.59 to 1.526 -> NumberFormatException occurs during maven 3 build After upgrade from 1.519 to 1.526 -> NumberFormatException occurs during maven 3 build
            marecki Marek Marzec made changes -
            Description {code}
            Started by timer
            [EnvInject] - Loading node environment variables.
            Building remotely on KO.LINUX.05 in workspace XXXx

            Cleaning up /var/lib/jenkins/workspace/fb_g3his.tea.wma-root_deploy/.

            Updating XXXXXX/wma.3.1.x-fb/wma-root at revision '2013-08-18T22:00:13.715 +0200'
            At revision 134474

            no change for http://XXXXXX/wma.3.1.x-fb/wma-root since the previous build

            Parsing POMs

            Downloaded artifacts.....

            [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar /var/lib/jenkins/maven3-interceptor-commons.jar 48798
            Exception in thread "main" java.lang.NumberFormatException: For input string: "/var/lib/jenkins/maven3-interceptor-commons.jar"
            at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
            at java.lang.Integer.parseInt(Integer.java:449)
            at java.lang.Integer.parseInt(Integer.java:499)
            at org.jvnet.hudson.maven3.agent.Maven3Main.main(Maven3Main.java:65)

            ERROR: Failed to launch Maven. Exit code = 1
            An attempt to send an e-mail to empty list of recipients, ignored.
            Notifying upstream projects of job completion
            Finished: FAILURE

            {code}
            h2. Other info:

            * What is funny that upgrade was done on Friday -> builds were working throught weekend without any biggers problems, on Monday this bug appears.

            * it affects about 50% of builds of most projects - undeterministic ...
            When builds passed corresponding maven line has the same content just different number:

            {code}
            [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar 46450
            {code}

            * when I rollback to 1.519 its gone


            * after week once again upgraded but to 1.527 and the same bug shown

            * rollback to 1.519 helped..



            I can deliver more info just need to know what...


            Builds of type Maven2/3 Build.

            {code}
            Started by timer
            [EnvInject] - Loading node environment variables.
            Building remotely on KO.LINUX.05 in workspace XXXx

            Cleaning up /var/lib/jenkins/workspace/fb_g3his.tea.wma-root_deploy/.

            Updating XXXXXX/wma.3.1.x-fb/wma-root at revision '2013-08-18T22:00:13.715 +0200'
            At revision 134474

            no change for http://XXXXXX/wma.3.1.x-fb/wma-root since the previous build

            Parsing POMs

            Downloaded artifacts.....

            [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar /var/lib/jenkins/maven3-interceptor-commons.jar 48798
            Exception in thread "main" java.lang.NumberFormatException: For input string: "/var/lib/jenkins/maven3-interceptor-commons.jar"
            at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
            at java.lang.Integer.parseInt(Integer.java:449)
            at java.lang.Integer.parseInt(Integer.java:499)
            at org.jvnet.hudson.maven3.agent.Maven3Main.main(Maven3Main.java:65)

            ERROR: Failed to launch Maven. Exit code = 1
            An attempt to send an e-mail to empty list of recipients, ignored.
            Notifying upstream projects of job completion
            Finished: FAILURE

            {code}
            h2. Other info:

            * What is funny that upgrade was done on Friday -> builds were working throught weekend without any biggers problems, on Monday this bug appears.

            * it affects about 50% of builds of most projects - undeterministic ...
            When builds passed corresponding maven line has the different numbers or arguments - without "/var/lib/jenkins/maven3-interceptor-commons.jar"

            {code}
            [wma-root_deploy] $ /var/lib/jenkins/tools/jdk/jdk1.6.0_45/bin/java -Xmx580M -cp /var/lib/jenkins/maven3-agent.jar:/var/lib/jenkins/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar org.jvnet.hudson.maven3.agent.Maven3Main /var/lib/jenkins/tools/maven/apache-maven-3.0.4 /var/lib/jenkins/slave.jar /var/lib/jenkins/maven3-interceptor.jar 46450
            {code}

            * when I rollback to 1.519 its gone


            * after week once again upgraded but to 1.527 and the same bug shown

            * rollback to 1.519 helped..



            I can deliver more info just need to know what...


            jglick Jesse Glick made changes -
            Link This issue is blocking JENKINS-16261 [ JENKINS-16261 ]
            jglick Jesse Glick made changes -
            Link This issue is blocking JENKINS-16261 [ JENKINS-16261 ]
            jglick Jesse Glick made changes -
            Link This issue is blocking JENKINS-15935 [ JENKINS-15935 ]
            jglick Jesse Glick made changes -
            Assignee olamy [ olamy ]
            jglick Jesse Glick made changes -
            Assignee olamy [ olamy ] Jesse Glick [ jglick ]
            jglick Jesse Glick made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jglick Jesse Glick made changes -
            Labels lts-candidate
            scm_issue_link SCM/JIRA link daemon made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            olivergondza Oliver Gond┼ża made changes -
            Labels lts-candidate 1.532.1-fixed
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 150699 ] JNJira + In-Review [ 193634 ]

            People

              jglick Jesse Glick
              marecki Marek Marzec
              Votes:
              4 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: