Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19291

'Trigger only the parent job' property is not saved in multi-configuration project with Email-ext plugin

    XMLWordPrintable

Details

    Description

      Steps to reproduce:

      1. Install Email-ext plugin;
      2. Create default multi-configuration project;
      3. Select several nodes to run the job in multi-configuration project;
      4. Add post-build action -> Editable Email Notification;
      5. Set 'Trigger for matrix projects' = Trigger only the parent job -> Apply changes;
      6. Reopen job configuration and observe the value of 'Trigger for matrix projects' property.

      Attachments

        Issue Links

          Activity

            oleksii_ielysieiev Oleksii Ielysieiev created issue -
            slide_o_mix Alex Earl made changes -
            Field Original Value New Value
            Status Open [ 1 ] In Progress [ 3 ]

            Code changed in jenkins
            User: Alex Earl
            Path:
            src/main/java/hudson/plugins/emailext/ExtendedEmailPublisherDescriptor.java
            src/main/resources/hudson/plugins/emailext/ExtendedEmailPublisher/config.groovy
            http://jenkins-ci.org/commit/email-ext-plugin/0bd7b7ed460cf6854a9481616d046f59626c1bd7
            Log:
            Fix JENKINS-19291

            Fixed the name of the item used to set the matrix mode internally.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Alex Earl Path: src/main/java/hudson/plugins/emailext/ExtendedEmailPublisherDescriptor.java src/main/resources/hudson/plugins/emailext/ExtendedEmailPublisher/config.groovy http://jenkins-ci.org/commit/email-ext-plugin/0bd7b7ed460cf6854a9481616d046f59626c1bd7 Log: Fix JENKINS-19291 Fixed the name of the item used to set the matrix mode internally.
            slide_o_mix Alex Earl added a comment -

            Fixed the name of the property used to get the trigger mode.

            slide_o_mix Alex Earl added a comment - Fixed the name of the property used to get the trigger mode.
            slide_o_mix Alex Earl made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            hossinho Ali Hosseini added a comment -

            Hi Alex, Some other fields are also not sticking. Only changes to "Attach Build Log" and "Content Type" seem to stick for me. I am not able to set and save the following fields:
            Project Recipient List
            Project Reply-To List
            Default Subject
            Default Content
            Pre-send Script
            Trigger for matrix projects (you already fixed)

            I'm also using version 2.32

            Thanks.

            hossinho Ali Hosseini added a comment - Hi Alex, Some other fields are also not sticking. Only changes to "Attach Build Log" and "Content Type" seem to stick for me. I am not able to set and save the following fields: Project Recipient List Project Reply-To List Default Subject Default Content Pre-send Script Trigger for matrix projects (you already fixed) I'm also using version 2.32 Thanks.
            slide_o_mix Alex Earl added a comment -

            I can't seem to replicate that type of issue, the matrix field was for sure, it wasn't using the correct field name to save off from, but the other fields save just fine for me. I'm using 2.32 in my production with no issues (I don't use matrix builds, so I didn't see that issue before).

            slide_o_mix Alex Earl added a comment - I can't seem to replicate that type of issue, the matrix field was for sure, it wasn't using the correct field name to save off from, but the other fields save just fine for me. I'm using 2.32 in my production with no issues (I don't use matrix builds, so I didn't see that issue before).
            slide_o_mix Alex Earl added a comment -

            Do you have an errors in the Jenkins logs? I just verified that the fields that the plugin uses to get those items are correct.

            slide_o_mix Alex Earl added a comment - Do you have an errors in the Jenkins logs? I just verified that the fields that the plugin uses to get those items are correct.
            hossinho Ali Hosseini added a comment -

            Thanks for the quick response. Ok I'll investigate further. I just noticed our Jenkins version is 1.509.2, I'll try to update to 1.528 and see if that fixes the issue.

            hossinho Ali Hosseini added a comment - Thanks for the quick response. Ok I'll investigate further. I just noticed our Jenkins version is 1.509.2, I'll try to update to 1.528 and see if that fixes the issue.
            slide_o_mix Alex Earl added a comment -

            1.509.2 should work, that is the version that the plugin is tested against.

            slide_o_mix Alex Earl added a comment - 1.509.2 should work, that is the version that the plugin is tested against.
            hossinho Ali Hosseini added a comment -

            There's no error log entry for it.
            But I looked inside config.xml, under this element:
            <hudson.plugins.emailext.ExtendedEmailPublisher plugin="email-ext@2.32">

            and the values of the fields, do reflect the changes I made!!! So "write" seems to be working correctly. Maybe it's just a "read" issue.

            (By the way, because of another bug, I currently can't complete a build to see if email-ext will actually carry-out the changes I made. but the XML is correct)

            hossinho Ali Hosseini added a comment - There's no error log entry for it. But I looked inside config.xml, under this element: <hudson.plugins.emailext.ExtendedEmailPublisher plugin="email-ext@2.32"> and the values of the fields, do reflect the changes I made!!! So "write" seems to be working correctly. Maybe it's just a "read" issue. (By the way, because of another bug, I currently can't complete a build to see if email-ext will actually carry-out the changes I made. but the XML is correct)
            slide_o_mix Alex Earl made changes -
            Link This issue is duplicated by JENKINS-19363 [ JENKINS-19363 ]
            mmlegra Matt Legrand added a comment -

            I have also run into this problem, and I am using jenkins 1.528 and the plugin v2.32.
            Note that when I changed the "Trigger for Matrix projects" field and clicked the "Apply" button the config.xml file did not change. That might help in diagnosis.

            mmlegra Matt Legrand added a comment - I have also run into this problem, and I am using jenkins 1.528 and the plugin v2.32. Note that when I changed the "Trigger for Matrix projects" field and clicked the "Apply" button the config.xml file did not change. That might help in diagnosis.
            slide_o_mix Alex Earl added a comment -

            The issue with the matrix settings will be fixed in the next version of the plugin.

            slide_o_mix Alex Earl added a comment - The issue with the matrix settings will be fixed in the next version of the plugin.

            Hit the same problem with Email-ext and Multi Configuration today.
            "Trigger for matrix projects" value sticks to "Trigger for parent and each configuration".
            Version: Jenkins 1.527, Email-Ext: 2.32

            vvladymyrov Volodymyr Vladymyrov added a comment - Hit the same problem with Email-ext and Multi Configuration today. "Trigger for matrix projects" value sticks to "Trigger for parent and each configuration". Version: Jenkins 1.527, Email-Ext: 2.32
            slide_o_mix Alex Earl added a comment -

            Yes, I still need to do a release, been hectic at work.

            slide_o_mix Alex Earl added a comment - Yes, I still need to do a release, been hectic at work.

            Thanks for looking into this. This is minor and definitely is not a show stopper. Thanks for great plugin. We are happily using it in our company for sending build reports.

            vvladymyrov Volodymyr Vladymyrov added a comment - Thanks for looking into this. This is minor and definitely is not a show stopper. Thanks for great plugin. We are happily using it in our company for sending build reports.
            mmlegra Matt Legrand added a comment -

            Agree - this is a great plugin.

            mmlegra Matt Legrand added a comment - Agree - this is a great plugin.
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 150739 ] JNJira + In-Review [ 193651 ]

            People

              slide_o_mix Alex Earl
              oleksii_ielysieiev Oleksii Ielysieiev
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: