Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19445

Jobs randomly stuck with "building remotely on slave-name" message



    • Similar Issues:


      Hi folks,

      Last week, I started to experience a weird issue with freezing/endless waiting of building jobs on slave machines. It first started with WinXP 32 bit slave, but I'm now experiencing the same problem also with WinXP 64 bit slave.

      The symptoms are like this...
      The job is started by SCM change or predefined time.
      Both slave machines are correctly started (the last line, in their respective logs, says "Slave successfully connected and online").
      Now the problem is, that the last line in console says "Building remotely on slave-name..." and there is just scrolling the progress circle. Nothing else happens. No GIT or SVN activity, no building, no testing, simply nothing and it stays like that until I kill the job manually.

      Sometimes, the problem happens with just one machine, and the other one runs OK. But today it struck both machines.

      Last week, when the problem started, I tried to update the Jenkins and both slaves with the most recent versions and latest plugins (except the "Git Client Plugin", because of a known issue with building history). Few hours all worked great, then the problem reappeared.

      Please see the attached files with logs and thread dumps from both slave machines.

      What struck me is the high number of threads started on both machines, which looks really weird? But I don't understand Jenkins that deep so I can't say for sure if it's normal or not?

      Any idea what to try or how to solve this behavior?

      Have a nice day,


        1. LB3D-MASTER_05_09_13.txt
          53 kB
        2. LB3D-MASTER.txt
          41 kB
        3. LB3D-Wxpp32sp3_05_09_13.txt
          6 kB
        4. LB3D-Wxpp32sp3.txt
          89 kB
        5. LB3D-Wxpp64sp2_05_09_13.txt
          7 kB
        6. LB3D-Wxpp64sp2.txt
          92 kB
        7. remoting-2.47.patch
          2 kB
        8. threadump.txt
          9 kB

          Issue Links


            odklizec Pavel Kudrys created issue -
            odklizec Pavel Kudrys made changes -
            Field Original Value New Value
            Attachment LB3D-MASTER.txt [ 24305 ]
            odklizec Pavel Kudrys made changes -
            Attachment LB3D-Wxpp32sp3_05_09_13.txt [ 24306 ]
            Attachment LB3D-Wxpp64sp2_05_09_13.txt [ 24307 ]
            Attachment LB3D-MASTER_05_09_13.txt [ 24308 ]
            vmarin Valentin Marin made changes -
            Priority Major [ 3 ] Critical [ 2 ]
            schristou Steven Christou made changes -
            Assignee Steven Christou [ schristou ]
            bbva BBVA made changes -
            Rank Ranked higher
            bbva BBVA made changes -
            Attachment remoting-2.47.patch [ 32417 ]
            olivergondza Oliver Gond┼ża made changes -
            Labels 1.651.3-fixed
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 150894 ] JNJira + In-Review [ 193724 ]
            drtaddei Dave Taddei made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            drtaddei Dave Taddei made changes -
            Attachment threadump.txt [ 33588 ]
            gregcovertsmith Greg Smith made changes -
            Link This issue is related to JENKINS-39179 [ JENKINS-39179 ]


              schristou Steven Christou
              odklizec Pavel Kudrys
              14 Vote for this issue
              26 Start watching this issue