Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19525

Dynamic Axis Plugin sometimes inserts "default" axis even when it shouldn't

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I am using dynamic axis on job that can run concurrently.
      The plugin evaluate axis by on of the job's parameters.
      If (and only if) this parameter is empty, the plugin should set one value to the axis called "dafault".

      The issue is that sometimes even when this parameter is not empty, the plugin adds the value "default" to the axis, causing undefined runs to the build.

      From initial look at the code, I suggest it uses Java collection that doesn't support concurrent runs, not synchronized.

      Found another thread on it on the web.

        Attachments

          Activity

          or_shachar Or Shachar created issue -
          kckane Kevin Kane made changes -
          Field Original Value New Value
          Assignee Or Shachar [ or_shachar ]
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          or_shachar Or Shachar made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 150979 ] JNJira + In-Review [ 206930 ]

            People

            Assignee:
            or_shachar Or Shachar
            Reporter:
            or_shachar Or Shachar
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: