Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19720

Jenkins Loses Build History

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Duplicate
    • core
    • None
    • Ubuntu Master
      2 Ubuntu slaves
      2 Windows Slaves

    Description

      recently upgraded system from Hudson to Jenkins(1.522)
      We have now had 3 reported instances where all the build history for a project randomly disappears. There seems to be no rhyme or reason for it. No recent modifications to the project.

      This is a extremely critical problem

      I see that other similar issues have been opened and closed several times

      Need a permanent resolution...quickly

      Attachments

        Issue Links

          Activity

            yshossel Yakov Shossel added a comment -

            I have same problem in 1.509.1
            Sometimes, the history disappeared in job and $(BUILDS_ALL_TIME) was reset to 0.

            After restart of jenkins, the job history is back, but build number must be set manually.

            yshossel Yakov Shossel added a comment - I have same problem in 1.509.1 Sometimes, the history disappeared in job and $(BUILDS_ALL_TIME) was reset to 0. After restart of jenkins, the job history is back, but build number must be set manually.
            danielbeck Daniel Beck added a comment -

            Possible duplicate of JENKINS-18678 or JENKINS-18694

            danielbeck Daniel Beck added a comment - Possible duplicate of JENKINS-18678 or JENKINS-18694
            kuene212chow Queenie Chow added a comment - - edited

            I have the same problem in ver. 1.538 (deployed on wls 12c on rhel 6). After reload configure, stop or start Jenkins, or restart on managed server, loses build history.

            kuene212chow Queenie Chow added a comment - - edited I have the same problem in ver. 1.538 (deployed on wls 12c on rhel 6). After reload configure, stop or start Jenkins, or restart on managed server, loses build history.
            gavingray Gavin Gray added a comment -

            Just saw this on 1.532.1.

            gavingray Gavin Gray added a comment - Just saw this on 1.532.1.
            oleg_nenashev Oleg Nenashev added a comment -

            I suppose the issue has been resolved since 1.532.2 (JENKINS-18678).
            Marking as resolved/duplicate. Please re-open if the issue appears on older versions

            oleg_nenashev Oleg Nenashev added a comment - I suppose the issue has been resolved since 1.532.2 ( JENKINS-18678 ). Marking as resolved/duplicate. Please re-open if the issue appears on older versions
            kuene212chow Queenie Chow added a comment -

            I have the same problem in ver. 1.538 (deployed on wls 12c on rhel 6). After reload configure, stop or start Jenkins, or restart on managed server, loses build history.

            kuene212chow Queenie Chow added a comment - I have the same problem in ver. 1.538 (deployed on wls 12c on rhel 6). After reload configure, stop or start Jenkins, or restart on managed server, loses build history.
            danielbeck Daniel Beck added a comment -

            kuene212chow: Your Jenkins version is likely too old for any investigation into the issue. JENKINS-18678 was fixed in 1.546 for example. If you could reproduce this on 1.554.x or 1.560+, that'd be more interesting.

            If it still occurs on those more recent versions, please file a new bug and provide relevant log excerpts, information on the contents of JENKINS_HOME (do the builds exist on disk?) and information on your Jenkins configuration (e.g. the global configuration setting "Builds Dir Location" in Configure Jenkins » Advanced).

            danielbeck Daniel Beck added a comment - kuene212chow : Your Jenkins version is likely too old for any investigation into the issue. JENKINS-18678 was fixed in 1.546 for example. If you could reproduce this on 1.554.x or 1.560+, that'd be more interesting. If it still occurs on those more recent versions, please file a new bug and provide relevant log excerpts, information on the contents of JENKINS_HOME (do the builds exist on disk?) and information on your Jenkins configuration (e.g. the global configuration setting "Builds Dir Location" in Configure Jenkins » Advanced).
            abh239 Amit Bhardwaj added a comment -

            I just experienced same problem on version 1.624. All history is gone after I installed "Copy Artifact Plugin" and restarted Jenkins. Build number is kept intact as I ran a new build and number given is next in the series what was there before jenkins restart. Kindly suggest what should be done in this regard ?

            abh239 Amit Bhardwaj added a comment - I just experienced same problem on version 1.624. All history is gone after I installed "Copy Artifact Plugin" and restarted Jenkins. Build number is kept intact as I ran a new build and number given is next in the series what was there before jenkins restart. Kindly suggest what should be done in this regard ?
            oleg_nenashev Oleg Nenashev added a comment -

            abh239, it should be another issue. Please create a new JIRA ticket and attach the system logs there

            oleg_nenashev Oleg Nenashev added a comment - abh239 , it should be another issue. Please create a new JIRA ticket and attach the system logs there

            People

              Unassigned Unassigned
              jweeks915 Jim Weeks
              Votes:
              5 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: