Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20307

Job status page shows "Build has been executing for null on master"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins v 1.357
      Windows 7
      Windows service
    • Similar Issues:

      Description

      I was watching the build page, and saw that the following text to the upper right "Build has been executing for null on master"

      I was not expected "null" in the message

        Attachments

          Issue Links

            Activity

            redsolo redsolo created issue -
            chr0n1x Kevin R. added a comment -

            bump

            I am also seeing this on Centos 6.4, Jenkins 1.537.

            danielbeck Daniel Beck added a comment -

            What job types are affected by this?

            oleg_nenashev Oleg Nenashev added a comment -

            Please reopen the issue if it appears on newer core versions

            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Resolved [ 5 ]
            danielbeck Daniel Beck added a comment -

            Oleg: Really? 1.537 is at least somewhat recent (1.532.3 released on April 11)… FWIW I'm seeing this on 1.532.3 with Build Flow occasionally, hence the question.

            Unless you feel that 1.537 is too obsolete, I'd reopen this.

            oleg_nenashev Oleg Nenashev added a comment -

            Jenkins v 1.357

            BTW, it could be just a typo.
            If you see the issue for 1.532, lets reopen it

            oleg_nenashev Oleg Nenashev made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            danielbeck Daniel Beck added a comment -

            Oleg: See comment by Kevin R.

            danielbeck Daniel Beck added a comment -

            Resolving as Incomplete after ~2 months without response to comment asking for additional information.

            danielbeck Daniel Beck made changes -
            Resolution Incomplete [ 4 ]
            Status Reopened [ 4 ] Resolved [ 5 ]
            mrose Michael Rose added a comment -

            I am seeing this issue on version 1.559 for my multi-configuration (matrix) project.

            Started 6 min 42 sec ago
            Build has been executing for null on

            danielbeck Daniel Beck added a comment -

            Michael:

            Which of the Matrix builds shows this message? The parent? A regular configuration's build?
            Is there no node name specified (i.e. 'Build has been executing for null on' rather than 'Build has been executing for null on master' as described above)?

            mrose Michael Rose added a comment -

            It is the parent. The configuration build seem to have the correct description.

            Sorry I accidentally clipped off the host last time. The on "HOSTNAME" portion of the string is correct.

            Started 46 sec ago
            Build has been executing for null on b261806

            danielbeck Daniel Beck made changes -
            Assignee Daniel Beck [ danielbeck ]
            Resolution Incomplete [ 4 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            danielbeck Daniel Beck added a comment -

            I'm almost sure I found the cause in Run.getExecutor().

            Workaround should be -Dhudson.model.Hudson.flyweightSupport=false, because it affects only Flyweight tasks that run on One-off executors.

            danielbeck Daniel Beck made changes -
            Status Reopened [ 4 ] Open [ 1 ]
            danielbeck Daniel Beck made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            danielbeck Daniel Beck made changes -
            Remote Link This issue links to "PR 1348 (Web Link)" [ 11203 ]
            jlongman jlongman added a comment -

            Also seeing this on 1.571 hosted on a FreeBSD 9.1 machine.

            Started 3 hr 21 min ago
            Build has been executing for null on xlicenses

            May be related to null time refereces in the build progress column plugin, which shows

            Started null ago
            Estimated time remaining null

            (May because the actual parent job has a non-null time for Started ago.)

            danielbeck Daniel Beck added a comment -

            See above linked PR 1348 for an explanation and proposed solution.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Daniel Beck
            Path:
            core/src/main/java/hudson/model/Run.java
            http://jenkins-ci.org/commit/jenkins/9379d1fefc49fbe8cf11bb96290a9924a6eb38cc
            Log:
            [FIXED JENKINS-20307] Consider OneOffExecutors in Run.getExecutor()

            scm_issue_link SCM/JIRA link daemon made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Daniel Beck
            Path:
            core/src/main/java/hudson/model/Run.java
            http://jenkins-ci.org/commit/jenkins/fe3b33a16e850f1e5a5fd80b06b3484eb6f4bf98
            Log:
            Merge pull request #1348 from daniel-beck/JENKINS-20307

            [FIXED JENKINS-20307] Consider OneOffExecutors in Run.getExecutor()

            Compare: https://github.com/jenkinsci/jenkins/compare/174786b9f758...fe3b33a16e85

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #3651
            [FIXED JENKINS-20307] Consider OneOffExecutors in Run.getExecutor() (Revision 9379d1fefc49fbe8cf11bb96290a9924a6eb38cc)

            Result = SUCCESS
            daniel-beck : 9379d1fefc49fbe8cf11bb96290a9924a6eb38cc
            Files :

            • core/src/main/java/hudson/model/Run.java
            guptapranav01 Pranav Gupta added a comment -

            I ran the following script to run the jenkins jobs

            import hudson.console.HyperlinkNote
            import java.util.concurrent.CancellationException
            import com.tikal.jenkins.plugins.multijob.MultiJobProject
            import hudson.model.*
            import hudson.AbortException

            job = hudson.model.Hudson.instance.items.each { job ->
            try {
            def running = job.lastBuild.building
            def disabled = job.isDisabled()
            def numbuilds = job.builds.size()
            lastbuild = job.builds[0]
            if (numbuilds == 0)

            { println job.name + ' has 0 previous build' }

            else if (running) {
            println "${job.name} is already running. Not launching"
            } else if (disabled) {
            println "${job.name} is disabled...Cannot be kicked off"
            } else {
            def buildParameter = job.builds[0].getAction(ParametersAction.class)
            if (buildParameter == null)

            { job.newBuild() println job.name + ' starts running...' }

            }
            } catch(Exception e)

            { println job.name + ' -> ' + e.getMessage() }

            }

            The jobs shows blinking green button but they are not running.
            Message : Build has been executing for null on master

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 151831 ] JNJira + In-Review [ 194111 ]

              People

              Assignee:
              danielbeck Daniel Beck
              Reporter:
              redsolo redsolo
              Votes:
              2 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: