Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20363

Implement option in GUI to disable checkpointing feature

    XMLWordPrintable

Details

    Description

      When running two or more unrelated concurrent builds of the same project in Jenkins, some of the builds do not complete until the first build has completed. This is caused by the publish-over-cifs plugin and we see the following message in the console logs of the slaves that are affected: Send build artifacts to a windows share is waiting for a checkpoint on CAD Conversions #1040 . It would be great if this checkpoint feature could be turned off on a per-project basis with an option like "Don't wait for other concurrent builds to complete"

      Attachments

        Activity

          whitlabell Gary Bell created issue -
          whitlabell Gary Bell added a comment - see also: https://issues.jenkins-ci.org/browse/JENKINS-9913
          whitlabell Gary Bell made changes -
          Field Original Value New Value
          Description When running two or more *unrelated* builds of the same project in Jenkins, some of the builds do not complete until the first build has completed. This is caused by the publish-over-cifs plugin and we see the following message in the console logs of the slaves that are affected: {{Send build artifacts to a windows share is waiting for a checkpoint on CAD Conversions #1040}} . It would be great if this checkpoint feature could be turned off on a per-project basis with an option like "Don't wait for other concurrent builds to complete" When running two or more *unrelated* concurrent builds of the same project in Jenkins, some of the builds do not complete until the first build has completed. This is caused by the publish-over-cifs plugin and we see the following message in the console logs of the slaves that are affected: {{Send build artifacts to a windows share is waiting for a checkpoint on CAD Conversions #1040}} . It would be great if this checkpoint feature could be turned off on a per-project basis with an option like "Don't wait for other concurrent builds to complete"
          jglick Jesse Glick made changes -
          Labels BuildMonitor checkpoint cifs delay jenkins, post-build BuildMonitor checkpoint cifs delay post-build
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 151887 ] JNJira + In-Review [ 178097 ]
          slide_o_mix Alex Earl made changes -
          Assignee bap [ bap ] Alex Earl [ slide_o_mix ]
          slide_o_mix Alex Earl added a comment -

          Is this still an issue?

          slide_o_mix Alex Earl added a comment - Is this still an issue?
          whitlabell Gary Bell added a comment -

          Hi Alex. The job that exhibited the underlying issue isn't really used much so we don't see concurrent builds any more. I'll try and reproduce it and report back. But in any case this ticket was an improvement suggestion, so I think that it would still be useful to have this feature as I believe the underlying problem is caused by individual plugins not using the correct process for checkpointing. Giving the User control over this at a project level is the best way to avoid hung executors until all plugins are updated.

          whitlabell Gary Bell added a comment - Hi Alex. The job that exhibited the underlying issue isn't really used much so we don't see concurrent builds any more. I'll try and reproduce it and report back. But in any case this ticket was an improvement suggestion, so I think that it would still be useful to have this feature as I believe the underlying problem is caused by individual plugins not using the correct process for checkpointing. Giving the User control over this at a project level is the best way to avoid hung executors until all plugins are updated.
          whitlabell Gary Bell added a comment -

          I constructed an artificial test case to check this and I can no longer reproduce the problem using our current Jenkins v1.651.1 and Publish over cifs v0.3 plugin. This means that we no longer need the enhancement requested in this ticket. The enhancement may be generally useful however in the case where other plugins are misbehaving in a similar manner.

          whitlabell Gary Bell added a comment - I constructed an artificial test case to check this and I can no longer reproduce the problem using our current Jenkins v1.651.1 and Publish over cifs v0.3 plugin. This means that we no longer need the enhancement requested in this ticket. The enhancement may be generally useful however in the case where other plugins are misbehaving in a similar manner.
          slide_o_mix Alex Earl made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]

          For your information, all publish-over-cifs component type JENKINS issues related to the Publish Over CIFS plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues

          Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues/50
          And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-cifs-plugin/issues?q=%22JENKINS-20363%22

          (Note: this is an automated bulk comment)

          gmcdonald Gavin McDonald added a comment - For your information, all publish-over-cifs component type JENKINS issues related to the Publish Over CIFS plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-cifs-plugin/issues/50 And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-cifs-plugin/issues?q=%22JENKINS-20363%22 (Note: this is an automated bulk comment)

          People

            slide_o_mix Alex Earl
            whitlabell Gary Bell
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: