Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21978

Couldn't find any revision to build. Verify the repository and branch configuration for this job.

    XMLWordPrintable

Details

    Description

      After updating from git 1.5 to 2.0.3 and git-client from 1.3 to 1.6.3, I get the following message when I try to build from a tag:

      ERROR: Couldn't find any revision to build. Verify the repository and branch configuration for this job.

      Building from master works fine, I'm using the "Branch Specifier" field and "refs/tags/1.7.12" or "tags/1.7.12" as input.

      Attachments

        Issue Links

          Activity

            flaviodonze Flavio Donzé created issue -
            bsundsrud Benn Sundsrud added a comment -

            We're seeing the same error in 2.0.3 on Jenkins 1.552 trying to build tags/$tagVersion passed in via build param. Other builds that specify branches work fine, only building tags fails. Rolling back the git plugin to 2.0 works, leaving git-client 1.6.3.

            bsundsrud Benn Sundsrud added a comment - We're seeing the same error in 2.0.3 on Jenkins 1.552 trying to build tags/$tagVersion passed in via build param. Other builds that specify branches work fine, only building tags fails. Rolling back the git plugin to 2.0 works, leaving git-client 1.6.3.
            markewaite Mark Waite added a comment -

            Duplicate of JENKINS-21952

            markewaite Mark Waite added a comment - Duplicate of JENKINS-21952
            markewaite Mark Waite made changes -
            Field Original Value New Value
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            markewaite Mark Waite made changes -
            Link This issue duplicates JENKINS-21952 [ JENKINS-21952 ]
            markewaite Mark Waite added a comment -

            The git client plugin 1.10.0 accepts a broader range of specifications for the branch to build, and allows tag builds using that broader range of specifications for branch to build.

            Refer to the online help for the "Branches to build" field for examples of the syntax which is accepted and the meaning of those items

            markewaite Mark Waite added a comment - The git client plugin 1.10.0 accepts a broader range of specifications for the branch to build, and allows tag builds using that broader range of specifications for branch to build. Refer to the online help for the "Branches to build" field for examples of the syntax which is accepted and the meaning of those items
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 154055 ] JNJira + In-Review [ 207457 ]

            People

              ndeloof Nicolas De Loof
              flaviodonze Flavio Donzé
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: