Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23026

Parameterized build can not save the "Parameter Description" in the first time

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins latest version 1.563
    • Similar Issues:

      Description

      Job -> Configuration -> This build is parameterized -> "add some kind of parameter" -> "enter some description" -> Save

      For this case, we do the 1st "Save" action, it doesn't make sense. the "description" disappear.
      We need to re-configuration for the Job parameter description. Save in 2ed time.

        Attachments

          Issue Links

            Activity

            xiaopan3322 Bao Xiaopan(Bob) created issue -
            danielbeck Daniel Beck added a comment -

            Reducing priority as workaround is easy and obvious, and parameter descriptions are only a UI element.

            danielbeck Daniel Beck made changes -
            Field Original Value New Value
            Priority Critical [ 2 ] Minor [ 4 ]
            christutty Chris Tutty added a comment -

            Seriously Daniel? "...only a UI element"? I use descriptions to comment parameter dependencies and guide input. That's like saying code comments aren't required by the parser so they're not important. Throwing away user input should always be treated as a critical fault, but I'm new here.

            danielbeck Daniel Beck added a comment -

            Yes, I'm serious (I could be wrong though). While there is "loss of data", it's a parameter description, not your released build (or even a script like JENKINS-23151). Let's not overrate it.

            danielbeck Daniel Beck made changes -
            Link This issue is related to JENKINS-23151 [ JENKINS-23151 ]
            christutty Chris Tutty added a comment -

            I withdraw (after reading the definition of "Major" while posting a related bug which I obviously should have done before commenting). It's the kind of thing that I don't like seeing trivialised, but I think you're correct in assessing it as Minor.

            danielbeck Daniel Beck added a comment -

            As mentioned in the comments to JENKINS-23148, the new CodeMirror also breaks accessibility for blind users.

            danielbeck Daniel Beck made changes -
            Link This issue is related to JENKINS-23148 [ JENKINS-23148 ]
            donato73 Donato Tagliabue added a comment -

            Hi, I've the same problem. The behaviour is the same as in Jenkins-23151 bug. The workaround also in this case is to "apply" the modifications (the new build parameter description) before saving

            ircbot Jenkins IRC Bot made changes -
            Component/s parameters [ 15594 ]
            danielbeck Daniel Beck made changes -
            Labels codemirror
            danielbeck Daniel Beck added a comment -

            Another workaround if using "Safe HTML" markup formatter: Disable syntax highlighting.

            jglick Jesse Glick added a comment -

            This is essentially a duplicate of JENKINS-23151, though affecting a different textarea this time.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Vojtech Juranek
            Path:
            core/src/main/resources/hudson/tasks/Shell/config.groovy
            core/src/main/resources/lib/form/textarea/textarea.js
            http://jenkins-ci.org/commit/jenkins/4e48eaa05ca3a76fcb0e1eee307fd20f222079bc
            Log:
            [FIXED JENKINS-23151, JENKINS-23026] Save CodeMirror editor when it loses focus

            • Save CM editor when it loses focus to ensure that test is saved back to textarea
            • Turn on again CM editor for shell scripts
            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #3935
            [FIXED JENKINS-23151, JENKINS-23026] Save CodeMirror editor when it loses focus (Revision 4e48eaa05ca3a76fcb0e1eee307fd20f222079bc)

            Result = UNSTABLE
            vojtech juranek : 4e48eaa05ca3a76fcb0e1eee307fd20f222079bc
            Files :

            • core/src/main/resources/lib/form/textarea/textarea.js
            • core/src/main/resources/hudson/tasks/Shell/config.groovy
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 155347 ] JNJira + In-Review [ 179042 ]
            danielbeck Daniel Beck added a comment -

            Appears to have been fixed in Jan 2015.

            danielbeck Daniel Beck made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: ikedam
            Path:
            src/main/resources/hudson/plugins/matrix_configuration_parameter/MatrixCombinationsParameterDefinition/config.jelly
            http://jenkins-ci.org/commit/matrix-combinations-plugin/cabe08ab7a000a835f41950653e41348f020aa7c
            Log:
            JENKINS-42902 Disable codemirror

            codemirror feature for dynamic fragments are affected by JENKINS-23026 till Jenkins 1.597.


              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              xiaopan3322 Bao Xiaopan(Bob)
              Votes:
              2 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: