Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23531

MSTest Plugin - MSTestPublisher aborted due to exception : Getting an error because "&# could not be transformed

    XMLWordPrintable

Details

    Description

      Hello,

      I'm getting an the following errors, because "&# couldn't be transformed - this characters occur when JustMock writes certain exceptions,
      could there be a way not to abort the build when this happens?

      thanks a lot!

      Processing tests results in file(s) Test\TestResults\testResults.trx
       Test\TestResults\testResults.trx
      ERROR: Publisher hudson.plugins.mstest.MSTestPublisher aborted due to exception
      java.io.IOException: remote file operation failed: c:\jenkins\workspace\Build - Tests at hudson.remoting.Channel@69bf0fd8:build3
      	at hudson.FilePath.act(FilePath.java:916)
      	at hudson.FilePath.act(FilePath.java:893)
      	at hudson.plugins.mstest.MSTestPublisher.perform(MSTestPublisher.java:73)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:745)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:709)
      	at hudson.model.Build$BuildExecution.post2(Build.java:182)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:658)
      	at hudson.model.Run.execute(Run.java:1735)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:231)
      Caused by: hudson.util.IOException2: Could not transform the MSTest report. Please report this issue to the plugin author
      	at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:66)
      	at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:28)
      	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2474)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:328)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at hudson.remoting.Engine$1$1.run(Engine.java:63)
      	at java.lang.Thread.run(Unknown Source)
      Caused by: javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Character reference "&#
      	at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source)
      	at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source)
      	at hudson.plugins.mstest.MSTestReportConverter.transform(MSTestReportConverter.java:63)
      	at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:64)
      	... 12 more
      Caused by: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Character reference "&#
      	at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(Unknown Source)
      	... 16 more
      Caused by: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Character reference "&#
      	at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(Unknown Source)
      	at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(Unknown Source)
      	... 17 more
      

      Attachments

        Activity

          knpe Peter Stefan Knittl-Frank created issue -
          jessejacob Jesse Jacob added a comment -

          This is definitely a bug in MSTest allowing unescaped text to be added directly to the XML file. Do you know what version of the MSTest runner you're on? If you're referencing a super old version like 2008 or 2010, I would be very interested to know if the problem is fixed by using e.g. mstest.exe from the 2013 folder.

          jessejacob Jesse Jacob added a comment - This is definitely a bug in MSTest allowing unescaped text to be added directly to the XML file. Do you know what version of the MSTest runner you're on? If you're referencing a super old version like 2008 or 2010, I would be very interested to know if the problem is fixed by using e.g. mstest.exe from the 2013 folder.
          nilleb Ivo Bellin Salarin made changes -
          Field Original Value New Value
          Assignee acmarques [ acmarques ] Ivo Bellin Salarin [ nilleb ]

          Code changed in jenkins
          User: nilleb
          Path:
          src/test/resources/hudson/plugins/mstest/JENKINS-13862.trx
          src/test/resources/hudson/plugins/mstest/JENKINS-17506.trx
          src/test/resources/hudson/plugins/mstest/JENKINS-23531-xmlentities-forged.trx
          http://jenkins-ci.org/commit/mstest-plugin/ffafe38f2ed88a3b59cfae57fae3b275d2cb0b1e
          Log:
          JENKINS-23531 test material

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: nilleb Path: src/test/resources/hudson/plugins/mstest/ JENKINS-13862 .trx src/test/resources/hudson/plugins/mstest/ JENKINS-17506 .trx src/test/resources/hudson/plugins/mstest/ JENKINS-23531 -xmlentities-forged.trx http://jenkins-ci.org/commit/mstest-plugin/ffafe38f2ed88a3b59cfae57fae3b275d2cb0b1e Log: JENKINS-23531 test material

          Code changed in jenkins
          User: nilleb
          Path:
          src/main/java/hudson/plugins/mstest/ContentCorrector.java
          src/main/java/hudson/plugins/mstest/MSTestTransformer.java
          src/test/java/hudson/plugins/mstest/MSTestTransformerTest.java
          http://jenkins-ci.org/commit/mstest-plugin/f8b7527131cd235f3fbaa7238e87e3b1ab04e85a
          Log:
          [FIXED JENKINS-23531] ignore invalid xml entities

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: nilleb Path: src/main/java/hudson/plugins/mstest/ContentCorrector.java src/main/java/hudson/plugins/mstest/MSTestTransformer.java src/test/java/hudson/plugins/mstest/MSTestTransformerTest.java http://jenkins-ci.org/commit/mstest-plugin/f8b7527131cd235f3fbaa7238e87e3b1ab04e85a Log: [FIXED JENKINS-23531] ignore invalid xml entities
          scm_issue_link SCM/JIRA link daemon made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          jijohn J John added a comment - - edited

          I am getting the same issue for:

          • Jenkins version 1.608
          • MsTest Plugin version 0.14.
          • Microsoft (R) Build Engine version 12.0.30723.0
          • Microsoft .NET Framework, version 4.0.30319.34209

          Below is the exception stack trace:

          MSTest: Processing tests results in file(s) Tests\*.trx
          MSTest: E:\workspace\Tests\file.trx
          [MSTEST] XML coverage report file not found: E:\workspace\Tests\mstest-coverage.xml
          [MSTEST] XML coverage report file not found: E:\workspace\Tests\436745.coveragexml
          MSTest: E:\workspace\Tests\file.trx
          [MSTEST] XML coverage report file not found: E:\workspace\Tests\mstest-coverage.xml
          [MSTEST] XML coverage report file not found: E:\workspace\Tests\216227.coveragexml
          MSTest: E:\workspace\Tests\file.trx
          ERROR: Publisher hudson.plugins.mstest.MSTestPublisher aborted due to exception
          java.io.IOException: remote file operation failed: E:\workspace at hudson.remoting.Channel@4c494212:apim-jenkins-s1: hudson.remoting.ProxyException: java.io.IOException: MSTest: Could not transform the MSTest report. Please report this issue to the plugin author
          	at hudson.FilePath.act(FilePath.java:985)
          	at hudson.FilePath.act(FilePath.java:967)
          	at hudson.plugins.mstest.MSTestPublisher.perform(MSTestPublisher.java:99)
          	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721)
          	at hudson.model.Build$BuildExecution.post2(Build.java:183)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670)
          	at hudson.model.Run.execute(Run.java:1775)
          	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          	at hudson.model.ResourceController.execute(ResourceController.java:89)
          	at hudson.model.Executor.run(Executor.java:240)
          Caused by: hudson.remoting.ProxyException: java.io.IOException: MSTest: Could not transform the MSTest report. Please report this issue to the plugin author
          	at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:66)
          	at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:24)
          	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2688)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          	at hudson.remoting.Request$2.run(Request.java:328)
          	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          	at java.util.concurrent.FutureTask.run(Unknown Source)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          	at hudson.remoting.Engine$1$1.run(Engine.java:63)
          	at java.lang.Thread.run(Unknown Source)
          	at ......remote call to apim-jenkins-s1(Native Method)
          	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
          	at hudson.remoting.UserResponse.retrieve(UserRequest.java:221)
          	at hudson.remoting.Channel.call(Channel.java:752)
          	at hudson.FilePath.act(FilePath.java:978)
          	... 11 more
          Caused by: hudson.remoting.ProxyException: javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Invalid byte 2 of 2-byte UTF-8 sequence.
          	at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source)
          	at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source)
          	at hudson.plugins.mstest.XslTransformer.transform(XslTransformer.java:51)
          	at hudson.plugins.mstest.MSTestReportConverter.transform(MSTestReportConverter.java:144)
          	at hudson.plugins.mstest.MSTestReportConverter.transform(MSTestReportConverter.java:68)
          	at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:64)
          	at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:24)
          	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2688)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
          	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          	at hudson.remoting.Request$2.run(Request.java:328)
          	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          	at java.util.concurrent.FutureTask.run(Unknown Source)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          	at hudson.remoting.Engine$1$1.run(Engine.java:63)
          	at java.lang.Thread.run(Unknown Source)
          Caused by: hudson.remoting.ProxyException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Invalid byte 2 of 2-byte UTF-8 sequence.
          	at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(Unknown Source)
          	... 17 more
          Caused by: hudson.remoting.ProxyException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Invalid byte 2 of 2-byte UTF-8 sequence.
          	at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(Unknown Source)
          	at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(Unknown Source)
          	... 18 more
          
          jijohn J John added a comment - - edited I am getting the same issue for: Jenkins version 1.608 MsTest Plugin version 0.14. Microsoft (R) Build Engine version 12.0.30723.0 Microsoft .NET Framework, version 4.0.30319.34209 Below is the exception stack trace: MSTest: Processing tests results in file(s) Tests\*.trx MSTest: E:\workspace\Tests\file.trx [MSTEST] XML coverage report file not found: E:\workspace\Tests\mstest-coverage.xml [MSTEST] XML coverage report file not found: E:\workspace\Tests\436745.coveragexml MSTest: E:\workspace\Tests\file.trx [MSTEST] XML coverage report file not found: E:\workspace\Tests\mstest-coverage.xml [MSTEST] XML coverage report file not found: E:\workspace\Tests\216227.coveragexml MSTest: E:\workspace\Tests\file.trx ERROR: Publisher hudson.plugins.mstest.MSTestPublisher aborted due to exception java.io.IOException: remote file operation failed: E:\workspace at hudson.remoting.Channel@4c494212:apim-jenkins-s1: hudson.remoting.ProxyException: java.io.IOException: MSTest: Could not transform the MSTest report. Please report this issue to the plugin author at hudson.FilePath.act(FilePath.java:985) at hudson.FilePath.act(FilePath.java:967) at hudson.plugins.mstest.MSTestPublisher.perform(MSTestPublisher.java:99) at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20) at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:761) at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:721) at hudson.model.Build$BuildExecution.post2(Build.java:183) at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:670) at hudson.model.Run.execute(Run.java:1775) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:89) at hudson.model.Executor.run(Executor.java:240) Caused by: hudson.remoting.ProxyException: java.io.IOException: MSTest: Could not transform the MSTest report. Please report this issue to the plugin author at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:66) at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:24) at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2688) at hudson.remoting.UserRequest.perform(UserRequest.java:118) at hudson.remoting.UserRequest.perform(UserRequest.java:48) at hudson.remoting.Request$2.run(Request.java:328) at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72) at java.util.concurrent.FutureTask.run(Unknown Source) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at hudson.remoting.Engine$1$1.run(Engine.java:63) at java.lang.Thread.run(Unknown Source) at ......remote call to apim-jenkins-s1(Native Method) at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356) at hudson.remoting.UserResponse.retrieve(UserRequest.java:221) at hudson.remoting.Channel.call(Channel.java:752) at hudson.FilePath.act(FilePath.java:978) ... 11 more Caused by: hudson.remoting.ProxyException: javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Invalid byte 2 of 2-byte UTF-8 sequence. at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source) at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source) at hudson.plugins.mstest.XslTransformer.transform(XslTransformer.java:51) at hudson.plugins.mstest.MSTestReportConverter.transform(MSTestReportConverter.java:144) at hudson.plugins.mstest.MSTestReportConverter.transform(MSTestReportConverter.java:68) at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:64) at hudson.plugins.mstest.MSTestTransformer.invoke(MSTestTransformer.java:24) at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2688) at hudson.remoting.UserRequest.perform(UserRequest.java:118) at hudson.remoting.UserRequest.perform(UserRequest.java:48) at hudson.remoting.Request$2.run(Request.java:328) at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72) at java.util.concurrent.FutureTask.run(Unknown Source) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at hudson.remoting.Engine$1$1.run(Engine.java:63) at java.lang.Thread.run(Unknown Source) Caused by: hudson.remoting.ProxyException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Invalid byte 2 of 2-byte UTF-8 sequence. at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(Unknown Source) ... 17 more Caused by: hudson.remoting.ProxyException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Invalid byte 2 of 2-byte UTF-8 sequence. at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(Unknown Source) at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(Unknown Source) ... 18 more
          jijohn J John made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]

          Code changed in jenkins
          User: nilleb
          Path:
          .idea/libraries/Maven__xmlunit_xmlunit_1_1.xml
          src/main/java/hudson/plugins/mstest/ContentCorrector.java
          http://jenkins-ci.org/commit/mstest-plugin/25662302fb882e9b8d2e8e9420f66fec151c70b4
          Log:
          JENKINS-23531 preserve charsets (default java encoding: not UTF-8)

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: nilleb Path: .idea/libraries/Maven__xmlunit_xmlunit_1_1.xml src/main/java/hudson/plugins/mstest/ContentCorrector.java http://jenkins-ci.org/commit/mstest-plugin/25662302fb882e9b8d2e8e9420f66fec151c70b4 Log: JENKINS-23531 preserve charsets (default java encoding: not UTF-8)

          Code changed in jenkins
          User: nilleb
          Path:
          src/main/java/hudson/plugins/mstest/ContentCorrector.java
          http://jenkins-ci.org/commit/mstest-plugin/66fb6367e71661c9537e876063b939f4ca4372b3
          Log:
          JENKINS-23531 preserve charsets (assume UTF-8 for both input and output)

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: nilleb Path: src/main/java/hudson/plugins/mstest/ContentCorrector.java http://jenkins-ci.org/commit/mstest-plugin/66fb6367e71661c9537e876063b939f4ca4372b3 Log: JENKINS-23531 preserve charsets (assume UTF-8 for both input and output)
          nilleb Ivo Bellin Salarin made changes -
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Resolved [ 5 ]
          vishal vishal Mane added a comment - - edited

          I am also facing this issue my jenkins version is : 1.619 and Mstest version is :0.18

          please find attached trx file (SYSTEM_AD-JENKINS 2015-07-08 10_53_01.trx)

          vishal vishal Mane added a comment - - edited I am also facing this issue my jenkins version is : 1.619 and Mstest version is :0.18 please find attached trx file (SYSTEM_AD-JENKINS 2015-07-08 10_53_01.trx)
          vishal vishal Mane made changes -
          vishal vishal Mane added a comment -

          I am also facing this issue my jenkins version is : 1.619 and Mstest version is :0.18

          please find attached trx file (SYSTEM_AD-JENKINS 2015-07-08 10_53_01.trx)

          vishal vishal Mane added a comment - I am also facing this issue my jenkins version is : 1.619 and Mstest version is :0.18 please find attached trx file (SYSTEM_AD-JENKINS 2015-07-08 10_53_01.trx)
          vishal vishal Mane made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          vishal vishal Mane made changes -
          Status Reopened [ 4 ] Open [ 1 ]
          vishal vishal Mane made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          vishal vishal Mane made changes -
          Status In Progress [ 3 ] Open [ 1 ]
          vishal vishal Mane made changes -
          Priority Major [ 3 ] Blocker [ 1 ]
          vishal vishal Mane added a comment -

          Any one has anything on this issue please help me.

          vishal vishal Mane added a comment - Any one has anything on this issue please help me.

          vishal Mane, the file you've attached is not valid XML.

          Try one of the xml validators you can find online, or your favourite xml editor. Everyone will tell you the same message:
          The line
          DEBUG: S: LPUSH pubsub:LogQHotelBeds \Y\0�\0\0\0\0\0\0�g��ܶ%��J�?Xo�~i��s�RKǀ�&���і
          contains an invalid XML character entity. Which one? The  sequence.

          This means that your unit test outputs the given sequence. MSTest just copies it in the TRX. Without any further validation.

          In order to fix the mstest behavior, in the past I've patched the mstest plugin in order to skip invalid characters. I've skipped the ones explicitly listed in the official XML specification. Your character sequence doesn't appear in the official XML specification.

          Microsoft is aware of the problem (Jitin John, which reported an update on 4/9/2015 is from Microsoft). I'm not aware of a fix concerning vstest.console or mstest. Let's hope it will be included in VS2015 (which will be released on 07/20/2015).

          As a conclusion, you can do one of the following things:
          1) modify your unit tests from printing invalid xml character entities on StdOut or on the Debug trace.
          2) contact Microsoft in order to ask them to fix the problem in mstest and vstest.console.
          3) modify the code in ContentCorrector.java in order to add the given character sequence to the list of the invalid ones (and propose a pull request by means of the github interface).

          Have a good day,
          Ivo

          nilleb Ivo Bellin Salarin added a comment - vishal Mane, the file you've attached is not valid XML. Try one of the xml validators you can find online, or your favourite xml editor. Everyone will tell you the same message: The line DEBUG: S: LPUSH pubsub:LogQHotelBeds \Y\0�\0\0\0\0\0\0�g��ܶ%��J�?Xo�~i��s�RKǀ�&���і contains an invalid XML character entity. Which one? The  sequence. This means that your unit test outputs the given sequence. MSTest just copies it in the TRX. Without any further validation. In order to fix the mstest behavior, in the past I've patched the mstest plugin in order to skip invalid characters. I've skipped the ones explicitly listed in the official XML specification. Your character sequence doesn't appear in the official XML specification. Microsoft is aware of the problem (Jitin John, which reported an update on 4/9/2015 is from Microsoft). I'm not aware of a fix concerning vstest.console or mstest. Let's hope it will be included in VS2015 (which will be released on 07/20/2015). As a conclusion, you can do one of the following things: 1) modify your unit tests from printing invalid xml character entities on StdOut or on the Debug trace. 2) contact Microsoft in order to ask them to fix the problem in mstest and vstest.console. 3) modify the code in ContentCorrector.java in order to add the given character sequence to the list of the invalid ones (and propose a pull request by means of the github interface). Have a good day, Ivo

          Have a look at the previous comment, about the output of the unit test and the valididty of the attached XML.

          nilleb Ivo Bellin Salarin added a comment - Have a look at the previous comment, about the output of the unit test and the valididty of the attached XML.
          nilleb Ivo Bellin Salarin made changes -
          Resolution Won't Fix [ 2 ]
          Status Open [ 1 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 156311 ] JNJira + In-Review [ 207796 ]

          People

            nilleb Ivo Bellin Salarin
            knpe Peter Stefan Knittl-Frank
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: