Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23611

Role strategy: no way to provide users with the ability to add nodes without being an admin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I cannot provide users with the ability to add their own slaves to the system unless I grant them admin permission, which I obviously I rather not do.

        Attachments

          Activity

          ykaul Yaniv Kaul created issue -
          oleg_nenashev Oleg Nenashev added a comment -

          This case works correctly on 1.509.4 and 1.532.2
          You just need to add Slave.Create permission to a global non-admin role.

          If it does not work, please provide more info

          ykaul Yaniv Kaul added a comment -

          Please let me know what more information I can provide. All roles I have (but Anon) do have Slave.Create checked.
          I don't think they see the menu item of Manage Jenkins, so they can't get to the nodes sub-menu.

          oleg_nenashev Oleg Nenashev added a comment - - edited

          Do they have access to ${JENKINS_URL}/computer ?
          This link should be available on Jenkins page ("Build Executors" in the Queue side panel)

          P.S: ${JENKINS_URL}/manage is available for administrators only.

          oleg_nenashev Oleg Nenashev added a comment -

          No response from the requester.
          Works for me

          oleg_nenashev Oleg Nenashev made changes -
          Field Original Value New Value
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 156393 ] JNJira + In-Review [ 195397 ]

            People

            Assignee:
            oleg_nenashev Oleg Nenashev
            Reporter:
            ykaul Yaniv Kaul
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: