Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2364

No tasks are found when looking for "@todo" tasks

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • tasks-plugin
    • None
    • Platform: All, OS: All

    Description

      If I enter "@todo" into the task tag to look for, the task plugin will not find
      any tasks at all. But if I changed into "todo" it found 139 instances. @todo is
      used by doxygen to gather todo's in a report, but it would be nice if ther tasks
      plugin could find them.

      Steps to reproduce:
      1. Setup project to find @todo
      2. Create a file in the workspace containing " * @todo Move the default options
      to"
      3. Start the build

      Expected outcome:
      The task plugin would display 1 found task

      Actual outcome:
      No open tasks were found

      Tasks - 2.16
      Hudson 1.252

      Attachments

        Issue Links

          Activity

            redsolo redsolo created issue -
            drulli Ulli Hafner added a comment -

            Any ideas how to get this working without influencing issue 1738?

            drulli Ulli Hafner added a comment - Any ideas how to get this working without influencing issue 1738?
            drulli Ulli Hafner made changes -
            Field Original Value New Value
            Link This issue is blocking JENKINS-1738 [ JENKINS-1738 ]
            redsolo redsolo added a comment -

            If you are only looking for words, cant "\s[TAG\s" work as the regex?

            redsolo redsolo added a comment - If you are only looking for words, cant "\s[TAG\s" work as the regex?
            drulli Ulli Hafner added a comment -

            It's not that easy since words could be followed by punctuation characters.
            I need to parse the tags and change the expression depending on the first char.

            The following todos are valid now, please reopen if not:

            here is a @todo marker
            @todo at the beginning
            and one at the end @todo
            Text:@todo: this one, too
            Text@todo: this one, too

            drulli Ulli Hafner added a comment - It's not that easy since words could be followed by punctuation characters. I need to parse the tags and change the expression depending on the first char. The following todos are valid now, please reopen if not: here is a @todo marker @todo at the beginning and one at the end @todo Text:@todo: this one, too Text@todo: this one, too
            drulli Ulli Hafner made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            drulli Ulli Hafner added a comment -

            See TaskScannerTest.

            drulli Ulli Hafner added a comment - See TaskScannerTest.

            Code changed in hudson
            User: : drulli
            Path:
            trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/parser/TaskScanner.java
            trunk/hudson/plugins/tasks/src/test/java/hudson/plugins/tasks/parser/TaskScannerTest.java
            trunk/hudson/plugins/tasks/src/test/resources/hudson/plugins/tasks/parser/tasks-words-test.txt
            http://fisheye4.cenqua.com/changelog/hudson/?cs=12113
            Log:
            [FIXED JENKINS-2364] Adde support for tags with non-word characters (@todo)

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : drulli Path: trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/parser/TaskScanner.java trunk/hudson/plugins/tasks/src/test/java/hudson/plugins/tasks/parser/TaskScannerTest.java trunk/hudson/plugins/tasks/src/test/resources/hudson/plugins/tasks/parser/tasks-words-test.txt http://fisheye4.cenqua.com/changelog/hudson/?cs=12113 Log: [FIXED JENKINS-2364] Adde support for tags with non-word characters (@todo)
            scm_issue_link SCM/JIRA link daemon made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            abayer Andrew Bayer made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 132437 ] JNJira + In-Review [ 201410 ]

            People

              drulli Ulli Hafner
              redsolo redsolo
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: