Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24765

Jenkins doesn't escape commas when creating job URLs

    XMLWordPrintable

Details

    Description

      We create a matrix job, which has one of the axis as such:
      "test-124 | -m a,b"
      "test-125 | -m w,z"

      In the job's shell script we cut the 2nd half and turn it into our parameters for our application.
      This fails to create a proper URL for the job.
      Full example (note the "-m%20rc,d%20" - this is the issue):
      http://example.com:8080/view/View/job/HaComb_Snapshots_Test_Suite_Coverage/CMD=x5290_MP_FC_sym50_rcd1+rcd2_raid+on_SnapBackupTest_sas%7C-n%20sym50%20-m%20rc,d%20-r%20--dcbtest%20SnapBackupTest%20-g%20sas,label_exp=sustain&&single&&snap&&BoazS/

      Simple workaround we've used is convert all commas to underscore and later in our script re-set them to commas.

      Attachments

        Issue Links

          Activity

            ykaul Yaniv Kaul created issue -
            danielbeck Daniel Beck made changes -
            Field Original Value New Value
            Component/s matrix [ 15501 ]
            Component/s core [ 15593 ]
            danielbeck Daniel Beck made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            danielbeck Daniel Beck made changes -
            Link This issue duplicates JENKINS-12439 [ JENKINS-12439 ]
            ircbot Jenkins IRC Bot made changes -
            Component/s matrix-project [ 18765 ]
            Component/s matrix [ 15501 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 157803 ] JNJira + In-Review [ 195834 ]

            People

              Unassigned Unassigned
              ykaul Yaniv Kaul
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: