Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25153

Update ssh-slaves and ssh-credentials plugins in war file

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Docker
    • Similar Issues:

      Description

      I am trying to setup a Dockerfile for our Jenkins server. Here is my dockerfile: https://github.com/mtscout6/jenkins-docker/blob/master/jenkins-server/Dockerfile

      The problem I have is that the latest Docker plugin relies on ssh-slaves 1.8 and ssh-credentials 1.9. The jenkins war file is currently housing ssh-slaves 1.7 and ssh-credentials 1.8, when I tried adding those plugins to the war file they are replaced, but now I get a SHA-256 digest error. I'm sure this is because the checksum is now invalid as found in the META-INF/MANIFEST.MF file.

      I tried using the jar -uf command to update those plugins, also to no avail. What do I need to do to update these plugins so my docker container is ready to run right out of the gate?

      Here is the docker log output when running the docker container for the image defined by the above docker file: https://gist.github.com/mtscout6/a31298e1dcc5acf5863c.

      Thanks,
      Matt Smith

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              mtscout6 Matthew Smith
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: